Home Internet not activated due to pending request...

Home Internet not activated due to pending request...

Home Internet not activated due to pending request...

I'm a Participant Level 2

Home Internet not activated due to pending request...

Could someone here help me ? I signed up fido home internet on 7/27. The staff in the store told me it was activated the day I signed up and all I need to do is to install the router and set it up. Somehow it's just not as easy as she said. 5 days passed and it hasn't been activated. All I can see in my account is "You’ve got a pending request...." I'm feeling very frustrating right now.

3 REPLIES 3
Moderator

Hey @Madge, welcome to the community!

 

We're sad it has to be under these circumstances, 

 

Have you reached out to Internet Technical support?

 

What are the lights that are on in your modem? 

 

Let us know!



I'm a Participant Level 2

Hi Daniela,

Thanks for asking. It's all good now.

Today I called the tech support rep and was told the transaction was lost so I have to bring the router back to the store where I signed up 6 days ago. Funny thing was the store staff also had to call the tech support to re-activate my account again. The staff said I can call customer service to get the refund for the first 6 days. It's just simply ridiculous that I have to call the customer service which wasn't helpful in the first place.

Hey @Madge,

 

I understand your frustration. Have you called customer service already to have the situation taken care of? If not, we can definitely help you. 

 

Feel free to contact us here and we'll be happy to help you. Alternately we can send you a PM here on the Community.

 

Let us know! 😊