Travelling Abroad, phone not piggybacking

Reply
Highlighted
I'm a Participant Level 3
I'm a Participant Level 3

Travelling Abroad, phone not piggybacking

Hello, whenever I travel to the United States, my sony ericsson xperia ray (st18a) doesn't connect (piggyback) to any american network. The phone is fully unlocked, I typed in the code to check, *#*#7378423#*#*. It comes up as:

 

[ ] Network    0 

[ ] Network subset   0

[ ] Service Provider   0

[ ] Corporate   0

[ ] SIM   0

 

None of them have an X next to them.

Have used the phone for over a year, everything else works fine. Even when I put my sim card into another phone, such as a Nokia 1661, the same probelm exists. Could it be a probelm with my sim card or possibly my account with Fido?

 

Thanks

 

 

***Edited to add labels***

 

Accepted Solution

Re: Travelling Abroad, phone not piggybacking

Hi billybob,

 

I would suggest contacting customer service to see if there are any restrictions on your line that are preventing you from connecting to a US network. Click here for our contact us page.

View solution in context
Flag this to a Moderator
Message 1 of 3
1,296 Views
Highlighted
Community Manager
Community Manager
Solution

Re: Travelling Abroad, phone not piggybacking

Hi billybob,

 

I would suggest contacting customer service to see if there are any restrictions on your line that are preventing you from connecting to a US network. Click here for our contact us page.



Flag this to a Moderator
Message 2 of 3
1,266 Views
Highlighted
I'm a Participant Level 3
I'm a Participant Level 3

Re: Travelling Abroad, phone not piggybacking

Thanks, turns out I had a North American roaming block on my account.

Flag this to a Moderator
Message 3 of 3
1,250 Views