Samsung Galaxy Fit Shows Roaming, Doesn't connect to 3g

Reply
Highlighted
I'm a Participant Level 2
I'm a Participant Level 2

Samsung Galaxy Fit Shows Roaming, Doesn't connect to 3g

Hello!

I have an unlocked Samsung Galaxy Fit S5670. It is a 3G HSDPA 900 / 2100 phone. 

However, it shows roaming on the status bar. Though it still works fine and makes calls and text messages, I am unable to connect to the 3g network even if I purchase the add-on.

When I go MyAccount through the mobie browser, it shows that it is using Edge and not 3G, which is terribly slow and doesnt even work most of the time.

Is there a way to fix this problem? I have also added internet.fido.ca access points and all like shown in many threads on this forum.

Thank You!

 

 

***Edited to add labels***

Accepted Solution

Re: Samsung Galaxy Fit Shows Roaming, Doesn't connect to 3g

Hello, it shows roaming because its a non-fido phone, only fido phones with fido software do not show roaming.

As for 3G, you say your phone uses 900/2100. well hate to break it to you but fido's 3G uses 850 and 1900, so your phone will never connect to 3G.

Edge is a slower internet, so thats why when your on edge its much slower. If your goal was a smart phone with fast internet, this phone would not apply. sorry.
View solution in context
Flag this to a Moderator
Message 1 of 4
2,131 Views
Highlighted
I'm an Expert Level 2
I'm an Expert Level 2
Solution

Re: Samsung Galaxy Fit Shows Roaming, Doesn't connect to 3g

Hello, it shows roaming because its a non-fido phone, only fido phones with fido software do not show roaming.

As for 3G, you say your phone uses 900/2100. well hate to break it to you but fido's 3G uses 850 and 1900, so your phone will never connect to 3G.

Edge is a slower internet, so thats why when your on edge its much slower. If your goal was a smart phone with fast internet, this phone would not apply. sorry.
Flag this to a Moderator
Message 2 of 4
2,127 Views
Highlighted
I'm a Participant Level 2
I'm a Participant Level 2

Re: Samsung Galaxy Fit Shows Roaming, Doesn't connect to 3g

Thank You! 

Flag this to a Moderator
Message 3 of 4
2,116 Views
Highlighted
I'm Helpful Level 1
I'm Helpful Level 1

Re: Samsung Galaxy Fit Shows Roaming, Doesn't connect to 3g

Technically, Fido is roaming on Rogers network. If you can press *#0011# on the Samsung Fit, you can see that you are roaming on 302-720 (Rogers) network. In order for you to use any data, you need to enable data roaming in Wireless settings

The only way to get around the problem is to install the Canadian modem/radio file for your phone, but that phone is not even offered in Canada, so can't get it to work.
Flag this to a Moderator
Message 4 of 4
2,102 Views