Huawei P20 Pro Android Pie update cause GPS issues

Huawei P20 Pro Android Pie update cause GPS issues

Huawei P20 Pro Android Pie update cause GPS issues

SOLVED
I'm a Contributor Level 2

Huawei P20 Pro Android Pie update cause GPS issues

Hi guys, 

I have updated my Huawei P20 Pro to EMUI 9,0.0.178. After the update, GPS is not working properly. After reboot, the GPS is fine, but once I stopped navigation and start a new navigation, it keeps "Looking for GPS ...". I have tried GPS test app, it just could not get GPS fix. Whenever I need to navigate, I have to reboot the phone. I am wondering anyone is facing the same issue. I have wipe the cache partition but it did not help. I do not really want to do a factory reset. However, it seems that is the last resort I have. 

 

Thanks,

 


Screenshot_20190201_090932_com.google.android.apps.maps.jpgScreenshot_20190201_231750_com.chartcross.gpstest.jpg

Accepted Solution

Re: Huawei P20 Pro Android Pie update cause GPS issues

Solved by Community Manager

Hi everyone,

 

The February SMR along with a fix for this GPS issue will begin rolling out March 21. 

 

Thanks to everyone who reported this!

View solution in context
67 REPLIES 67
I'm a Participant Level 2

Can we have an idea when the fix will be coming? It's been weeks since I first began reporting issues to Fido and they just get me to reboot and have never told me that there was any communication with Huawei from your side. I need my GPS for work. This had been extremely frustrating and inconvenient. 

I'm a Participant Level 3

Just downgrade your system back to 8.1, there's nothing else we can do but to wait atm

 

My problem still exists every 24 hours, even though I originally thought it was permanently fixed.  Can't wait for the fix since rebooting phone every time I want to use GPS gets old.

I'm a Contributor Level 2

I will reset to Android 8 because I have to reboot everyday to get the GPS fixed.

Hi everyone,

 

The February SMR along with a fix for this GPS issue will begin rolling out March 21. 

 

Thanks to everyone who reported this!



I'm a Participant Level 3

Hi all, try this

Go to Settings-> Security & privacy-> Location access-> scroll down to Google location accuracy and disable it

Go back to location access -> adavanced settings-> disable Wifi scanning.

It works for me since 2 days.

It's a global issue with android 9.0

Hope it's the final solition

I'm a Participant Level 3

Since I tried this solution, the GPS works like a charm since i tried this solution 6 days ago, the gps works like a charm.

I'm a Participant Level 3

@Benmassaoud your solution didn't work for me.

I'm a Participant Level 3

For those of you who still have GPS issue, just downgrade it back to 8.1 with Hisuite, I can confirm it works and it is really easy to do

I'm a Participant Level 3

@Vincentyee : were you able to restore your data from the backup after downgrade to 8.1? Thanks.

I'm a Participant Level 3

Yes, just back up on Hisuite before you downgrade 

Hey everyone,

 

Huawei is working on a fix for this. I don't have a date as to when the update will become available, but I wanted to share what I know so far. I'll update this thread the moment I know more.



I'm a Participant Level 1

I have same problem now, need reboot to get it work every time,GPS fix apps not work.

I'm a Participant Level 3

I had same issue with GPS not working after EMUI9 update. Since then I did a lot of troubleshooting.

- reinstalling from scratch 

- reset cache etc. 

nothing worked, restart helps until next time I need to use GPS and I have to restart again. Even though it worked for time being after restart, GPS accuracy was very low. 

i tried to rollback to previous version 8.1 and  GPS functionality is back to normal. Once update applied it worked for about 8 hours and then stopped again.

My email to Huawei didn’t bring much info. 

So i rolled back again to EMUI 8.1 and GPS works as suppose to. I’ll wait until it is resolved. Obviously it is some nasty bug in EMUI 9

I'm a Participant Level 3

I reverted as well.  I am please there has been some success with it.

 

Super pleased Huawei offers to a tool to revert, also disappointed such a flawed update made it into the wild.  There seems to be a lot of GPS issues with Pie, checking on other forums.

I'm a Participant Level 3

Thx for the update, sent mine for fixing, problem still exits after that, i guess ill just roll back to 8.1

I'm a Participant Level 1

Same issue here, nothing seems to work for me. This issue has been quite a while already and it hasn't been fixed yet, it'll be nice to know when and what should we expect the fix to happen.

I'm a Participant Level 3

I have exactly the same issue after the update. I don't want to do a factory reset. Any other option?

I'm a Contributor Level 2

Maybe you can try to backup your phone with Huawei backup app through HiSense or on a micro SD card. Then reset your phone and restore your phone from backup. However, I am not sure if you can fix the issue by this way,

Knock on wood but things started to work on its own without a need to restart my phone in 6 days. Hopefully this is permanently

Thanks for your contribution @simonxcheng

 

Hey @Gabbie1977

 

Glad to hear that it's working for you! Thanks for keeping us posted🙂