HSPA+ , do I need to get my account provisioning updated? or?

Reply
Highlighted
I'm a Participant Level 2
I'm a Participant Level 2

HSPA+ , do I need to get my account provisioning updated? or?

Hello Folks,

 

So, I've done quite a bit using the customer support line from fido however there hasnt been a definitive solution.

 

Background:

1.) I have an unlocked HP Veer (AT&T) running webOS 2.1

2.) Newest Sim Card you can get

3.) HP Veer 4G is the official monicker for the phone, and supports FAUX G (4G NON-LTE aka 3G HSPA+)

 

Issue:

- I don't get 3G HSPA+ Connections in downtown Vancouver, BC or... anywhere

 

How do I know?
- Taking this phone down in Seattle WA, the symbol changed from 3G to H+ , H+ being HSPA+ or aka Faux G

- Sales rep for a fido store has a Galaxy S2 on fido, with HSPA+

 

What have I done?

- Updated APN Settings, they are currently set to:

 

apn: internet.fido.ca

username: fido

password: fico

 

This setting, I didn't need to input to access 3G connections but I put em on anyway but still no 3G HSPA+

 

- Updated my Sim Card, even though it was a NEW sim card - sales rep told me it might be my sim card

- Call Fido: "Sorry, we do not have HSPA+ or 4G HSPA+ or HSPA 4G" <-- this is after I spent five minutes describing to him what HSPA+ is and how its called "4G" but its not really 4G ..

 

Called Fido Again: "Sorry we do not have HSPA+ yet, we're still launching it next year"

 

Did they work?

 

Nope.

 

-- was wondering if I need to get my account activated for HSPA+ support .. what exactly is it that I need to do to have my phone recognize or be within the network's HSPA+ ? aka Faux G (4G)

 

 

***Edited to add labels***

Accepted Solution

Re: HSPA+ , do I need to get my account provisioning updated? or?

Hi everyone,

 

I'm not sure why you were both told that Fido does not have HSPA+. We most certainly do.

 

There is no specific account provisioning needed for HSPA+. As long as you have a compatible phone and a data add-on, you should be good to go.

 

Unfortunately it is hard for us at Fido to troubleshoot a non-Fido phone, so I will resurface this post to see if anyone in the community can help any further.

 

@ Community - can anyone shed some light?

View solution in context
Flag this to a Moderator
Message 1 of 4
2,050 Views
Highlighted
I'm a Participant Level 2
I'm a Participant Level 2

Re: HSPA+ , do I need to get my account provisioning updated? or?

I am having the EXACT same issue.

I called Fido TODAY and they told me they don't yet have HSPA+, which is wrong; they do.

Can a mod please answer this question? I'm not sure why there hasn't yet been a definitive answer, for months.
Flag this to a Moderator
Message 2 of 4
1,934 Views
Highlighted
I'm an Expert Level 2
I'm an Expert Level 2

Re: HSPA+ , do I need to get my account provisioning updated? or?

I remember last year using an unlocked Rodgers HSPA+ Rocket Stick with my fido sim, I was able to see the HSPA+ symbol on the connection manager when it connected to certain towers. I also did a few speed tests and low and behold it was hspa, i have the 6G internet plan, the normal one, not the LTE one and it worked just fine, no special plan was needed .

oh and HSPA+ is NOT LTE
Flag this to a Moderator
Message 3 of 4
1,927 Views
Highlighted
Community Manager
Community Manager
Solution

Re: HSPA+ , do I need to get my account provisioning updated? or?

Hi everyone,

 

I'm not sure why you were both told that Fido does not have HSPA+. We most certainly do.

 

There is no specific account provisioning needed for HSPA+. As long as you have a compatible phone and a data add-on, you should be good to go.

 

Unfortunately it is hard for us at Fido to troubleshoot a non-Fido phone, so I will resurface this post to see if anyone in the community can help any further.

 

@ Community - can anyone shed some light?



Flag this to a Moderator
Message 4 of 4
1,914 Views