VoLTE with Rogers but not with Fido?

VoLTE with Rogers but not with Fido?

VoLTE with Rogers but not with Fido?

Eddyv
I'm a Participant Level 3

VoLTE with Rogers but not with Fido?

I made the switch about a week ago from Freedom, my service for calls specifically has been abysmal. No matter the amount of bars I get on both 3G or 4G my calls either don't get any dial tone and end, are extremely choppy or they can't hear me at all. It sporadically will work but has been consistently bad. Data and text seem to work fine, including MMS. I have an unlocked ZTE Axon Ultra 30 (not bought from Freedom but directly from the manufacturer). This phone does have every band that Fido carries and I initially chalked the poor call quality to Fido not supporting this device for Volte (even though in the back of my mind I knew I should still be getting better service for calls with the 3G alone). What threw a wrench into my whole theory is that last night I put my friends Rogers SIM into my phone and I immediately got voLTE and crystal clear immediate connection. I just got off the phone with tech support and to be honest it felt like they weren't too confident in their responses, more so like they were going through the motions. I don't blame her, it's an unusual bug and when we did try to make a call it did work (as it sporadically would before). I just tried to call mums and it attempted for 20 seconds and call ended. They did open a ticket for me, but I thought I would try the forums and see if any if you folks might have an idea. I don't think specifically that the lack of Volte is the issue, but I do find it odd that it would work with a Rogers SIM without a hitch. I'm going to try my other friends Virgin SIM tonight. 

5 REPLIES 5
KAPABLE-K
MVP

Hello @Eddyv,

 

Welcome to the community!

 

If possible can you put your Fido SIM in your friend's phone and see if it works without issues? If you get problems it could possibly be a bad SIM.



Eddyv
I'm a Participant Level 3

I may of spoke to soon, so I tried his Rogers sim and it worked perfectly again. I got the VoLte notification and was able to make calls no problem. When he put my SIM into his device he was able to make calls but it dropped to H+ when the call was being made. Is it possible that I am somehow locked out of volte on my number or is it likely the SIM is the issue? Or lastly is it just possible that Fido and Rogers can't tell that we are swapping devices so immediately for them to deny my phone volte? 

Hello @Eddyv,

 

It is possible it could be your SIM I would start there, try changing the SIM, and also make sure you have the correct APN info see here for that.

If the new SIM does not solve the problem then you will have to get Fido technical department to look into it.



Eddyv
I'm a Participant Level 3

I went to a Fido store and they gave me a new SIM, the phone appeared to work for a couple minutes when I initially made a call afterwards. The second call I made in the food court of the mall where the Fido store is located failed. This was with full 4G/3G bars and calls started to fail afterwards. I don't believe it to be a volte issue anymore. I should have sufficient 3G for calls. The Fido rep double checked my APNs as well. I just tried my upstairs neighbors Virgin SIM and once again like my other buddy's Rogers SIM his number in my phone worked perfectly, he was able to call my number from my phone and vice versa. As soon as I put my Fido SIM back in my phone, my call failed with full bars and when he called me it went straight to voicemail. I'm so confused with what 0 idea with what could possibly be the culprit. Any other ideas you can possibly think of? 

Eddyv
I'm a Participant Level 3

Hmm, good call. I just attempted to put my SIM in my from Samsung unlocked S10 and it appears to work even on volte so It may not be the SIM. I'm going to try the Rogers SIM again in a bit when my friend is home, one person from Reddit thinks the VoLte I received from that SIM may be a fluke as it may of taken a bit for Rogers to realize it's not in one of their store bought phones to shut it off. Even so that doesn't explain the lack of connection I'm receiving on just 3G alone.