Special data plan

Special data plan

Special data plan

Luciel
I'm a Participant Level 1

Special data plan

I have tried and tried to get on to the "special" Data plan.

It is a Bunch of **bleep**!!!
I am so disappointed!!
i have changed my password as requested ad it still does not allow heck out their dea!!!
blah blah blah

1 REPLY 1

Hello @Luciel , good morning.  Sounds like you're having some difficulty with accessing extra data or signing up for a new offer.  If you could be more specific about what special data plan you are trying to access one of us would be able help you more efficiently. Is it the 5 extra hours or were you trying to sign up for a special offer? Are you having difficulty with the app or signing in on the website?  If it's the app, perhaps a restart of your phone and trying to sign in with a different browser like Chrome or Firefox, whichever one you didn't try yet. You could clear your cache in the browser and the app settings and then try again. If those don't work, you can uninstall the app and reinstall it and begin again. 

Also,  are you signing in with your email that's registered to your account or your phone number? Does that sign in work on the website for Fido.ca? 

Just a few things that come up when trying to solve a mystery. Please let us know if you require more help or if you resolved your issue with any of the suggestions, or with customer service on fido.ca, Twitter or Facebook. Any further information can be valuable to the community. 🙂 cheers