LTE not working on any other device other than my iPhone 5

LTE not working on any other device other than my iPhone 5

LTE not working on any other device other than my iPhone 5

I'm a Participant Level 2

LTE not working on any other device other than my iPhone 5

I'm not sure why I can't seem to get LTE reception at all on any device other than the iPhone 5 I got from Fido.  Prior to getting my iPhone 5,  I had a LTE iPad 3 and I've tried everything and could not get that to work.  The APN was set to ltemobile.apn as per the sim card I purchased at the time.  The Fido reps I spoke to on the phone kept on insisting that it is because I cut the LTE sim that I purchased down to the size of a micro sim,  I won't be able to get LTE reception and I would have to wait until fido as micro lte sims.  


After waiting about a month, I finally got my Fido iPhone 5 along with a new nano sim and I'm able to get LTE fine on that iPhone 5 without issue.  Today, I borrowed my friend's unlocked Samsung Galaxy Note and I'm still not able to get LTE reception on that device.  When I use the default APN of ltemobile.apn,  it will not connect to data at all.  If i change the APN to internet.fido.ca,  I'll have HSPA data but not LTE.  

 

Does anyone have any idea why this isn't working?  I have a feeling that this is account related and all the Fido reps I have spoken with were not helpful. 

 

 

***Edited to add labels***

1 REPLY 1
I'm a Participant Level 2

Ok looks like I figured it out.  On the Samsung Galaxy Note,  the APN needs to be spelt in all capitals or else it won't work. The default LTE APNs were all in lower case.   I now have LTE reception on the Samsung Galaxy Note.