Nexus 5 can't use LTE network

Reply
I'm a Participant Level 2 andrewmitra
I'm a Participant Level 2

Nexus 5 can't use LTE network

So I just got a new sim card from a Fido Kiosk, and it seems that my LTE accessing issue is still not fixed. I'm using a Nexus 5 unlocked that isn't a Fido phone however I can't connect to LTE or even 3G, just H and mostly E. The rep on the phone told me to get a new sim card which I did, but I'm wondering if I should have gotten standard Multi-Sim Card which is I belive the regular or an LTE Micro-Sim - if that is such a thing? Or is it my phone? 

 

 

 

Accepted Solution

Re: Nexus 5 can't use LTE network


andrewmitra wrote:

So I just got a new sim card from a Fido Kiosk, and it seems that my LTE accessing issue is still not fixed. I'm using a Nexus 5 unlocked that isn't a Fido phone however I can't connect to LTE or even 3G, just H and mostly E. The rep on the phone told me to get a new sim card which I did, but I'm wondering if I should have gotten standard Multi-Sim Card which is I belive the regular or an LTE Micro-Sim - if that is such a thing? Or is it my phone? 

 

 

***Edited to add labels***


Hello Andrewmitra,

 

  Welcome to the forums!

 

  Where did you purchase your Nexus 5? If it was outside of North America, you should note that the non-North American version only has one compatible band/frequency (NA version has two of the compatible bands; see here). While either version would work on the LTE network, coverage would depend on the bands/frequencies of the surrounding towers. You can verify the compatible bands here. You can get an idea of where the cellular towers are in your area here.

 

  You note that your phone accesses the networks with H. HSPA (H) and HSPA+ (H+) are data protocols using the UMTS/WCDMA network. So if your phone is showing H, then it's actually on the '3G' network. I'm not sure of the exact circumstances which changes the symbols. Phones may alternate between H & 3G for HSPA and H+ & 4G for HSPA+. However, you should be able to determine the network type in the phone's status settings.

 

  With regards to APN settings, since that phone is LTE, it should be using the single APN: ltemobile.apn.  You can verify the correct settings in @KAPABLE-K's post above or simplified here.

 

  If you purchased your phone overseas, you might also consider trying to turn roaming on. Some phones purchased abroad think they are roaming even though they might be using a local SIM.

 

**edit** Additionally, have you turned your data on? I seem to recollect an instance where a community member was also having issues with not getting LTE, but getting '3G' (and 2G). I don't remember the exact circumstances (ie might have been roaming data) but the fix was simply turning on data (or roaming data).**

 

  Hope this helps Smiley

 

Cheers

View solution in context
Flag this to a Moderator
Message 1 of 5
1,325 Views
I'm a Legend Level 1
I'm a Legend Level 1

Re: Nexus 5 can't use LTE network

Hi @andrewmitra

 

You will need to configure the APN settings to work with Fido. 

 

For full details see here.

 

Android is available on many devices and different versions exist in the market. Some of the names and information or settings below may vary depending on the device you have. This guide was made to provide instructions on as many devices and versions of the Android OS as possible starting from Android version 2.0.

  • Tap on Settings > Wireless & Networks > Mobile Networks > Access Point Names;
  • Once on the APN screen, press the Options button on the device;
  • Tap on New APN
  • Enter a name into the APN Name field.
  • Please insert the following APN settings:

    APN Settings:

    • APN: Fido-core-appl1.apn
    • If you have a LTE device, use the following setting: LTEMOBILE.APN

    MMS (Picture & Video Messaging Settings):

  • Leave the following fields blank: Proxy, Port, User Name, Password, Server
  • Press the Options button on your device, tap on Save in order to save the APN settings.
  • Restart the phone and try browsing the Internet.

NOTE: The created APN will show up on the APNs screen. To activate the APN, tap on the radio button located in front of APN.

Flag this to a Moderator
Message 2 of 5
1,322 Views
MVP
MVP
Solution

Re: Nexus 5 can't use LTE network


andrewmitra wrote:

So I just got a new sim card from a Fido Kiosk, and it seems that my LTE accessing issue is still not fixed. I'm using a Nexus 5 unlocked that isn't a Fido phone however I can't connect to LTE or even 3G, just H and mostly E. The rep on the phone told me to get a new sim card which I did, but I'm wondering if I should have gotten standard Multi-Sim Card which is I belive the regular or an LTE Micro-Sim - if that is such a thing? Or is it my phone? 

 

 

***Edited to add labels***


Hello Andrewmitra,

 

  Welcome to the forums!

 

  Where did you purchase your Nexus 5? If it was outside of North America, you should note that the non-North American version only has one compatible band/frequency (NA version has two of the compatible bands; see here). While either version would work on the LTE network, coverage would depend on the bands/frequencies of the surrounding towers. You can verify the compatible bands here. You can get an idea of where the cellular towers are in your area here.

 

  You note that your phone accesses the networks with H. HSPA (H) and HSPA+ (H+) are data protocols using the UMTS/WCDMA network. So if your phone is showing H, then it's actually on the '3G' network. I'm not sure of the exact circumstances which changes the symbols. Phones may alternate between H & 3G for HSPA and H+ & 4G for HSPA+. However, you should be able to determine the network type in the phone's status settings.

 

  With regards to APN settings, since that phone is LTE, it should be using the single APN: ltemobile.apn.  You can verify the correct settings in @KAPABLE-K's post above or simplified here.

 

  If you purchased your phone overseas, you might also consider trying to turn roaming on. Some phones purchased abroad think they are roaming even though they might be using a local SIM.

 

**edit** Additionally, have you turned your data on? I seem to recollect an instance where a community member was also having issues with not getting LTE, but getting '3G' (and 2G). I don't remember the exact circumstances (ie might have been roaming data) but the fix was simply turning on data (or roaming data).**

 

  Hope this helps Smiley

 

Cheers



Flag this to a Moderator
Message 3 of 5
1,313 Views
I'm a Contributor Level 1 j7
I'm a Contributor Level 1

Re: Nexus 5 can't use LTE network

nexus 5 works with fido LTE, no matter where you bought it in this planet

 

just setup LTE apn you are good go.

 

the capitalized APN LTEMOBILE.APN shown on the following fido guide is WRONG, it wasted me HOURS on that. 

 

 

probably the guide writer want to empasize that, so put it bold and capatalized.  

 

 

http://www.fido.ca/consumer/content/configure-unlocked-device-guide

 

The correct APN should be lowcased as ltemobile.apn  , that's case sensitive. i finally found that on rogers website

 

Flag this to a Moderator
Message 4 of 5
1,283 Views
Highlighted
MVP
MVP

Re: Nexus 5 can't use LTE network


j7 wrote:

nexus 5 works with fido LTE, no matter where you bought it in this planet

 

 

...

 


Hello J7,

 

  That statement is not necessarily true. The specifications from GSMArena (posted above) suggest the non-North American version only has band 7 or 2600 MHz as a compatible LTE band/frequency. I previously stated that the phones would work on the LTE networks but coverage would depend on the bands/frequencies of the surrounding towers. For example, that phone would NOT be able to access LTE in Manitoba because band 7 has not yet been deployed in that province (see here). Furthermore, not all bands/frequencies are available on every tower. So even if your area has a band/frequency deployed, it may not be available at the cell tower closest to your location.

 

Cheers



Flag this to a Moderator
Message 5 of 5
1,244 Views
Discussion stats
  • 4 replies
  • 1326 views
  • 3 likes
  • 4 in conversation