ZTE WF721 - Problems entering PINs or phone extensions

Reply
Highlighted
I'm a Participant Level 3 dguard
I'm a Participant Level 3

ZTE WF721 - Problems entering PINs or phone extensions

I have a Fido "home phone" using the ZTE WF721.  When I call a phone service requiring a PIN or extension number to be entered, the first digit of the PIN or extension number is always repeated.  For example:

 

(999) 555-1212 requires PIN 62345 followed by pound.  

 

So, I type in the phone number:

1-999-555-1212

 

Wait for the prompt to enter my PIN and I type in:

62345#

 

System responds with something like:

"The PIN you entered, six-six-two-three-four-five, is not valid.  Please try again."  (Always the first digit repeated)

 

It does not matter what phone device is attached and placing the call and it does not matter what service I'm trying to call so it seems like it is an issue with the ZTE.  And, it always the first digit of the PIN or extension no matter what that digit is.  Of course, this doesn't make much sense to me since it is the phone device that is issuing the DTMF signals.  The behaviour is as if the ZTE is inserting that extra leading digit.

 

Simple dialing of a phone number works fine.

 

Anyone else have a similar issue?

 

As an aside, the erratic behaviour of the message indicator light is also a continuing concern.

 

 

***Edited to add Labels***

Accepted Solution

Re: ZTE WF721 - Problems entering PINs or phone extensions

Hi everyone,

 

The update for the WF721 is now available. This update will improve touch tone performance and address a bug with the message waiting indicator.

 

Click here for more info.

View solution in context
Flag this to a Moderator
Message 1 of 84
30,615 Views
Highlighted
I'm a Participant Level 2 akwok
I'm a Participant Level 2

Re: ZTE WF721 - Problems entering PINs or phone extensions

Please advise if the touch tone issue is now resolved.

I tried 2 fido home phone boxes in Sep 2015 - both boxes had the same issue. I had to return both boxes. I will get the home phone again when the touch tone issue is fixed.

Flag this to a Moderator
Message 51 of 84
3,124 Views
Highlighted
Moderator
Moderator

Re: ZTE WF721 - Problems entering PINs or phone extensions

Hey @akwok and welcome to the Community Smiley

Our support team is still working on this. We will update you on this thread as soon as we get news on this.

 

Your patience is much appreciated Smiley



Flag this to a Moderator
Message 52 of 84
3,116 Views
Highlighted
I'm a Participant Level 2 akwok
I'm a Participant Level 2

Re: ZTE WF721 - Problems entering PINs or phone extensions

Thank you!

Flag this to a Moderator
Message 53 of 84
3,115 Views
Highlighted
Moderator
Moderator

Re: ZTE WF721 - Problems entering PINs or phone extensions

@akwok Anytime Smiley



Flag this to a Moderator
Message 54 of 84
3,114 Views
Highlighted
I'm a Participant Level 1 maniez106
I'm a Participant Level 1

Re: ZTE WF721 - Problems entering PINs or phone extensions

I switched our home phone from Bell to Fido months ago. Always have this same problem. Everytime we do phone banking with TD, CIBC or Tangerine where they would ask pin code or access number, it NEVER works on the home phone. I dialed but the operators kept saying I haven't punch it in. But if I use cell phone, it works. We never had this problem when we were with Bell so it is still the same hand held. We use Panasonnic Wireless.

 

Another prob with the home phone, it has it's own voice mail service. We also have answering machine connects to the hand held. When people leave a msg it will go to Fido voice mail which we think a bit taking time since we have to dial access code and so on and so on. So we would like to know how to deactivate voice mail on Fido but can get the message through our answering machine since it is easy, blinking light and press play and we hear the message without holding the hand held (I have a baby so rarely have free hand to hold the phone).

 

thanks for the reply

 

 

*Edited title

Flag this to a Moderator
Message 55 of 84
3,100 Views
Highlighted
I'm a Contributor Level 1 BMAN57
I'm a Contributor Level 1

Re: ZTE WF721 - Problems entering PINs or phone extensions

Still not working. Duplicating the first number when you have to enter more than 1 digit. Past 90 days since this was originally posted. 

Flag this to a Moderator
Message 56 of 84
2,980 Views
Highlighted
I'm a Contributor Level 2 Doogie87
I'm a Contributor Level 2

Re: ZTE WF721 - Problems entering PINs or phone extensions

This is so much. It is NOT a small percentage, it is more like everyone who has this device. I have had this and other problems for 7MONTHS. I somehow think that any solution is too expensive for FIDO to deal with.

 

 

***Edited for language***

Flag this to a Moderator
Message 57 of 84
2,979 Views
Highlighted
I'm a Contributor Level 1 kevinj31
I'm a Contributor Level 1

Re: ZTE WF721 - Problems entering PINs or phone extensions

Whenever I use my FHP to call my pharmacy's robot to refill a prescription, I can't.  I follow the prompts, and their system fails to recognize it.  I can use my Fido cell with no issues whatsoever.  I also run into this problem when I call the doctor's office.  It tells me to dial 9 for english, and i do, and their IVR just keeps nattering on in french, AND will not recognize the extension i enter to get to reception to make an appointment.  If i place the call with my fido cell phone it works just fine.

 

Please fix this Fido, it's driving me nutty!

 

**Edited title

Flag this to a Moderator
Message 58 of 84
2,965 Views
Highlighted
Former Moderator FidoTerry
Former Moderator

Re: ZTE WF721 - Problems entering PINs or phone extensions

Hey Kevinj31,

 

we're aware of this issue and we contact the manufacturer to launch a software update. We'll let everyone know when the fix is implemented. Smiley 

 

**Edited title



Flag this to a Moderator
Message 59 of 84
2,964 Views
Highlighted
I'm a Participant Level 2 JainONCA
I'm a Participant Level 2

Re: ZTE WF721 - Problems entering PINs or phone extensions

It has been more than six months now and this issue is still not fixed, i'm tempted to switch over to Rogers but realized they are using the same device. And knowing Fido & Rogers is technically the same, I guess the issue also exist with their service. I shall explore this option and will update this post.

Flag this to a Moderator
Message 60 of 84
2,861 Views