cancel
Showing results for 
Search instead for 
Did you mean: 

Foreign language Text/SMS messages are arriving as gibberish

Janddy
I'm a Participant Level 3
I'm a Participant Level 3

Hello.  When I receive SMS messages from recipients from another country in a foreign laguage, the message is arriving as english gibershish. It appears something is trying to translate them letter for letter into English and while that comes close for one or two words, it messes all the rest up.  How do I get the Fido service and my Iphone SE (running IOS 15) to allow foreign SMS messages to come through in their original language?

I used to be on a Rogers corporate account and did not have this problem. It started in the last 2 -3 months since moving my same device from Rogers to Fido.  

I have reviewed all my device settings based on apple recomendations and FIdo support.  The languages and keybords for the other languages I want to receive messages in (Greek and French) are loaded. FIdo support is at a loss on how to fix this but it is happening for me from multiple foreigh senders.   

Also, I can send messages in these langauges to others and they received them just fine.  It is just incoming messages from them that are being messed up.  

I do not know if this issue were to happen if the sender also had an iphone so they could send me an imessage instead.  My contacts do not have iphones so their messages are coming through as SMS/Text.

Any help from the brain trust on this forum?

Thank you.  

6 REPLIES 6

FidoPhilippe
Moderator
Moderator

Hey @Janddy! Philippe here.

I'll be happy to help you with that! I'll need to ask you a few questions though:

1. Are you using iMessages to send and receive your texts?

2. Is the translate option active under: Settings > Translate?

Let me know.



Janddy
I'm a Participant Level 3
I'm a Participant Level 3

Hi @FidoPhilippe ,  Thanks for your help with this.  Here are the answers to your questions:

1) This issue occurs with people that I am texting with and who do not have an iphone, so iMessage is not an option for them.  I have tested this with foreign contacts who have an iPhone and when we send text messages back and forth via iMessage, this issue does not occur.  The texts I receive through iMessage come through properly in their orginal langauge.  It is just something in texting that is trying to translate them or not recognizing the Keybaord / codec / character set the sender is using to send me the message. 

2) In Settings / Translate on my iPhone, Cellular Data is ON.   (It says this is to allow COM.APPLE.TRANSLATE to access Cellular data.  Hmm, I have not tried turnign this off and testing again.  I will try this. while I wait for your reply.)

Under Downloaded Languages on that screen, Greek is not an option to download so it is just a list of supported languages but none are downloaded.  

On-Device Mode is OFF 

Any thoughts?

John

Hey again @Janddy!

Has there been any change since you turned off the translator? It's highly likely that is the source of the problem, as the phone has a built-in translator.

Let us know.



Janddy
I'm a Participant Level 3
I'm a Participant Level 3

Hi @FidoPhilippe

I have had a chance to test this out and it appears that the issue has been resolved.  So, when having this issue on an iPhone (IOS 15),  if you go to Settings / Translate and turn, Cellular Data to OFF, it allows texts that are sent in foreign languages to be received in the foreign language without the devide trying to tranlsate. 

Thanks very much for your help!

Janddy
I'm a Participant Level 3
I'm a Participant Level 3

Hi.  Sorry, I have not been able to test yet as my contact has not responded.  I will advise once I have a chance to test.  Just give me a couple of days. 

Thanks

Hello Janddy,

  Welcome to the community!

  I understand you did not experience this type of receiving gibberish with your old Rogers corporate account, however, have you tried to have someone locally send you a text message in the specific language of issue? Alternatively, have you tried to send a message to yourself?

  If messages sent/received locally don't have the same problem, the issue could be a change in the way the foreign provider sends the text messages rather than the way the messages are translated.

Hope this helps 😀

Cheers