RCS not working

Reply
I'm a Participant Level 2 Ansh1
I'm a Participant Level 2

RCS not working

I recently bought an unlocked pixel 3, and put my Fido RCS sim card in it. But I have found RCS is not working. Whenever I go into Android messages settings and enable it, I get a losing screen for a few seconds, then it says "excuse the wait" and that it'll let me know when it's done (which it never does). I have tried erasing my cache, and the storage, as well as rebooting the phone but nothing seems to work. I did some research and found that Fido might need to reset my RCS profile, but the phone costumer support may have trouble understanding, so I'm hoping a supervisor or someone on this forum can help me?

Accepted Solution

Re: RCS not working

I have RCS working now, though I do not know if anything was done on Fido's end. But I followed the instructions in this thread -- https://forums.fido.ca/t5/forums/forumtopicpage/board-id/Smartphones/message-id/39244#M39244

 

For reference, here's what I did on my BYOD Pixel 2:

  1. Open Messages app
  2. Go to Play Store, search for "carrier services"
  3. Click on "Carrier Services" by Google LLC, which should be at the top of the results and show as installed
  4. Click on "Uninstall" and you'll be prompted as "Do you want to uninstall all updates to this Android system app?"
  5. Click "OK"
  6. Go back to the Messages app
  7. Go to Messages settings within the three dots "..." menu
  8. Go to the "Advanced" tab and click on "Enable Chat Features"
  9. You should see a small circle, followed by a bigger circle with a checkmark in the middle -- success!
  10. Go back to the "Carrier Services" app in the Play Store and click on "Update" to re-install any updates

 

YMMV but it worked for me.

 

Cheers,

Douglas

View solution in context
Flag this to a Moderator
Message 1 of 19
2,240 Views
I'm a Participant Level 2 Phodyssey
I'm a Participant Level 2

Re: RCS not working

When my friend and I were with Rogers, all of our messages sent with Google Messages (formely known as Android Messages) were RCS. I recently switched to Fido but my friend is still with Rogers. All of our messages are now sent as SMS, although we didn't change anything else and we both have RCS enabled.

 

How do I get to send and receive RCS messages again?

 

Thanks

Flag this to a Moderator
Message 16 of 19
118 Views
Moderator
Moderator

Re: RCS not working

Hey @Phodyssey,

 

Welcome to our Community!

 

I've moved your post to this existing thread as it treats the same topic.

 

Can you let us know if you're using a non Fido device at the moment? Also, just to clarify, you're not getting any error message when you enable RCS, correct?

 

Have you already tried clearing the cache and storage and rebooting the phone? You can also try to steps posted in the solution to see if that changes anything.

 

Keep us posted.

 

 

 

 



Flag this to a Moderator
Message 17 of 19
81 Views
I'm a Participant Level 2 Phodyssey
I'm a Participant Level 2

Re: RCS not working

I found a solution:

 

  1. Force close Google Messages
  2. Clear Google Messages data
  3. Uninstall Google Messages
  4. Reinstall Google Messages
  5. Open and enable RCS (it asks to by default)

Everything seems back to normal now.

 

Answers to the questions asked. My device was bought at Rogers but I'm now using a Fido SIM card. I was not getting any error message (I had tried several times to switch RCS off and back on). I also tried to clear cache, but that was insuffisant. The solution presented in this thread did not work either. I don't have Carrier Services installed on my device and never had before while RCS was working.

 

It looks like something went wrong when switching carriers, but I don't what exactly.

Flag this to a Moderator
Message 18 of 19
68 Views
Moderator
Moderator

Re: RCS not working

I'm glad you were able to get it sorted out, @Phodyssey!

 

And thanks for sharing, I'm sure it can be useful to others as well Smiley

 

 



Flag this to a Moderator
Message 19 of 19
53 Views