Interac payments througgh fido.ca not working but money gone form bank

Reply
Highlighted
I'm a Participant Level 2
I'm a Participant Level 2

Interac payments througgh fido.ca not working but money gone form bank

Twice I tried to pay my Fido bill through Interac via the website. Twice I was told the payment failed.

I just checked my bank account and the two payments have gone from my account but my Fido bill is still showing as unpaid.

Accepted Solution

Re: Interac payments througgh fido.ca not working but money gone form bank

Hey @bandit1980!

 

Don't worry! When making a payment using INTERAC Online, if your payment fails, the amount that was set aside to be applied towards your bill payment is refunded to your account within 24 to 48 hours of the failed transaction. 

 

If your payment was successful, it would have been applied to your account immediately.

 

That said, have you checked with your bank to make sure there is nothing preventing you from making your payment through INTERAC Online?

 

If you continue to experience difficulty using INTERAC Online, it may be a good idea to try making your payment using a different method of payment. You can check out this page in our Library for info on all the ways that you can pay your bill. 

 

 

View solution in context
Flag this to a Moderator
Message 1 of 12
2,502 Views
Highlighted
I'm a Participant Level 2
I'm a Participant Level 2

Re: Interac payments througgh fido.ca not working but money gone form bank

I know there is other options.

 

I want to pay the way I've been paying for the past  2 years to work. 

 

I called my bank multiple times and they say that Fido is blocking my payments. 

 

I call Fido and they say that they aren't. 

 

Why? 

 

Now I have to waste my day again and wait for my floating money to be put back into my account again before I can try and pay AGAIN. 

Flag this to a Moderator
Message 11 of 12
908 Views
Highlighted
Former Moderator
Former Moderator

Re: Interac payments througgh fido.ca not working but money gone form bank

We can definitely understand how this may be an inconvenience. Have you tried to clear your cache and cookies? This can help prevent issues. 

 

Keep us posted!

 

 



Flag this to a Moderator
Message 12 of 12
904 Views