iPhone has trouble switching from LTE to Wifi-Calling

iPhone has trouble switching from LTE to Wifi-Calling

iPhone has trouble switching from LTE to Wifi-Calling

SOLVED
TetraVaal
I'm Helpful Level 1

iPhone has trouble switching from LTE to Wifi-Calling

I have an iPhone 5c from the US and unlocked. 

 

When iOS 9 came out with the Wifi-Calling feature, I tried to activate it but was told this was not possible since my phone was not originaly from Fido, with a Canadian IMEI and it's unlocked. Bummer, but understandable.

 

But since the 9.3 update (9.3.2 currently) plus the latest carrier update (24.2), I can activate the feature and make/receive calls and send/receive SMS. Great! I live in a basement so that feature is real useful for me!

 

The problem is that multiple times, the phone won't switch from LTE to Fido Wi-Fi. Sometimes, it will switch, but after quite a while or I'll have to put the phone in airplane mode and switch it back to "normal" in order for it to "understand" that it has to connect to Fido Wi-Fi. 

 

Now, I'm not complaining since I know the feature is not really supported on non-Fido unlocked device, but since it's already working on mine, I'm thinking there's probably something in the system that prevent a quick transition from LTE to Wi-Fi Calling...

 

Proof that it works (when it does):

 

asset.PNG 

 

 

Accepted Solution

Re: iPhone has trouble switching from LTE to Wifi-Calling

Solved by I'm Helpful Level 1

Hey @FidoRanya and @FidoTerry

 

I think I found what the problem was. Like I said earlier, my Wi-Fi network is on 5Ghz. Previously, it was configured in 802.11a mode!

 

I have now changed my router settings to 802.11n with a channel width of 40Mhz. Obviously, this offers much better speed comparer to 802.11a! From what I saw, the connection to "Fido Wi-Fi" is quicker and more reliable. I think it's possible that Apple configured iOS to avoid Wi-Fi calls on 802.11a because of its slower speed and range. 

 

Also, for those interested in configuring QoS on their router for Wi-Fi Calling, the ports used are :

 

UDP 500 (IKEv2)

UDP 4500 (IKEv2)

 

This is from Apple's own documentation

 

Have a nice day!

View solution in context
5 REPLIES 5
FidoTerry
Former Moderator

Hey @TetraVaal

 

In most cases, when you have access to both the mobile network and Wi-Fi Calling (e.g., you have a Wi-Fi connection that is strong enough to be useable), your device will automatically default to using Wi-Fi Calling. This applies both when you are within Canada and when you are roaming outside of Canada.
 

Would it be possible that your phone isn't getting a strong enough Wi-Fi connection on your phone?



TetraVaal
I'm Helpful Level 1

Hello Terry,

 

My Wi-Fi connection is strong, as you can see in the screenshot. Usually, when I come back from work, I enter into my appartment and the phone will connect to my Wi-Fi (on 5Ghz) after a couple of seconds, but not "Fido Wi-Fi".  

 

Anyway, there was no problem today, so I'll see in a couple of days. I don't know if other folks with iPhones have the same issue with Wi-Fi Calling?

Hey @TetraVaal

 

Haven't heard anything like this so far on my end . Most of the time it either works perfectly or doesn't work at all. 

 

Could you find anything on the net? @Community anyone having the same issues?



TetraVaal
I'm Helpful Level 1

Hey @FidoRanya and @FidoTerry

 

I think I found what the problem was. Like I said earlier, my Wi-Fi network is on 5Ghz. Previously, it was configured in 802.11a mode!

 

I have now changed my router settings to 802.11n with a channel width of 40Mhz. Obviously, this offers much better speed comparer to 802.11a! From what I saw, the connection to "Fido Wi-Fi" is quicker and more reliable. I think it's possible that Apple configured iOS to avoid Wi-Fi calls on 802.11a because of its slower speed and range. 

 

Also, for those interested in configuring QoS on their router for Wi-Fi Calling, the ports used are :

 

UDP 500 (IKEv2)

UDP 4500 (IKEv2)

 

This is from Apple's own documentation

 

Have a nice day!

You're quite the expert Very_Happy

 

Thanks for keeping us posted @TetraVaal and for updating the thread , I'm sure it'll be very helpful!