can't get LTE on my S3

can't get LTE on my S3

can't get LTE on my S3

SOLVED
nisanity
I'm a Participant Level 1

can't get LTE on my S3

Hi guys,

I got my LTE Micro sim from Fido the other day for my unlocked S3.  Called up yesterday and today for them to check why my phone can't receive LTE but since it's not an official Fido phone... all they said is that my account is LTE ready and all they could do for me is to reset the "switch" for me and it should work.

 

I've browsed the forum and most of you guys got LTE to work just by putting in the sim... so I'm wondering if I'm missing something here?

 

I have both APN settings on my phone:
Fido-core-appl1.apn

Ltemobile.apn

 

and i'm still stuck in H+ and 3G.  Btw, I have the 6Gb data plan.

Thanks for your help.

 

 

 

Accepted Solution

Re: can't get LTE on my S3

Solved by I'm Experienced Level 3

To get LTE, you do not need the Fido-core APN. It's safe to get rid of that. There's something in your settings that may be off. Try inputting ltemobile.apn (all small letters). Post your current APN settings for the S3 and maybe get a visual of what might be the issue. Also see if the radio button on the ltemobile.apn is selected. Also check if the mobile settings are set to GSM, HSPA and LTE (auto). APN type, can be another issue. Another user aslo suggested using all caps for the LTE apn (ie. LTEMOBILE.APN).

View solution in context
3 REPLIES 3
Grandizer
I'm Experienced Level 3

To get LTE, you do not need the Fido-core APN. It's safe to get rid of that. There's something in your settings that may be off. Try inputting ltemobile.apn (all small letters). Post your current APN settings for the S3 and maybe get a visual of what might be the issue. Also see if the radio button on the ltemobile.apn is selected. Also check if the mobile settings are set to GSM, HSPA and LTE (auto). APN type, can be another issue. Another user aslo suggested using all caps for the LTE apn (ie. LTEMOBILE.APN).

anjp11
I'm a Participant Level 3

I have this same issue years later. Did you get it working?
FidoMegan
Former Moderator

Hey anjp11! 

 

I replied to your other post here! Smiley