ZTE WF720: Odd behavior when select callers go straight to voicemail

Reply
I'm a Participant Level 1 info4PJB
I'm a Participant Level 1

ZTE WF720: Odd behavior when select callers go straight to voicemail

Though this is a known issue, I have noticed some very specific odd behavior when my wireless home phone service goes straight to voicemail without ringing first. I have tried troubleshooting the ZTE WF720 device by getting missed callers to call back after I reboot the unit and/or switch the connected phone. The problem persists.

 

1. Consistently a Rogers home phone customer always goes to voicemail. The caller hears 4 or 5 rings but my connected phone(s) do not ring. Occassionsly a Wind Mobile customer has the same issue as do other callers.

2. When a missed call goes straight to voicemail, both the battery and signal strength indicators first go orange, turn off, and then the battery indicator comes back on as orange, changes to green and stays on before the signal indicator follows the same sequence. This does not occur for incoming voicemail calls that ring first.

3. Once the battery and signal indicators are both green, the voicemail indicator will start flashing to indicate a message.

4. Typically, calls that go to voicemail are not recorded/saved on the Caller ID (CID) list on my attached home phone.

 

I have been a Fido customer since 2006 and wonder whether something related to my services has been deleted or archived by Fido on the premise that they are old and not used by any existing customers. Something like this occurred on my cell service recently when all incoming calls were displayed as "unknown caller." The problem was eventually resolved by Fido technician.

 

Any thoughts or opinions?

 

 

 

Flag this to a Moderator
Message 1 of 15
2,115 Views
Former Moderator FidoManuel
Former Moderator

Re: ZTE WF720: Odd behavior when select callers go straight to voicemail

Hey there!

 

Welcome to the Community!

We haven't removed/expired anything that would create this behavior. The name display is not a feature available for Wireless Home Phone.

The WHP includes the call display, that will show the number but not the name. 

 

@Community Did any one else experienced this issue?



Flag this to a Moderator
Message 2 of 15
1,501 Views
I'm a Contributor Level 2 BTbtBT
I'm a Contributor Level 2

Re: ZTE WF720: Odd behavior when select callers go straight to voicemail

I have the same issue and have had this issue since switching to this "new modem".  And, yes, the new home phone modems do have name display.  

 

About a month ago, I noticed on my bill, a change to my home phone, adding name display to my line. I called and asked what it was about, and was told that the name display feature was added to my line because it is offered now on the home phone service.  I was then told that my current modem was an old model and wouldn't support the name display feature and to go in to a store and exchange the modem for a new model and it would be no charge (and also was told the store level is aware they should be doing this exchange, which they were not). Well, that was no small feat, or without hassle.  

 

My old modem would beep on calls - now this new one, as mentioned in the first post in this thread - calls will go directly to voicemail for no reason.  All the lights on the modem indicate that it is functional and online --- all green lights; full signal, full battery (plugged in anyways), online --- yet I get people calling my cell saying that my home phone line is going directly into voicemail.  No one is on the phone, it is showing that it is online and working, and if you pick up the phone, it will even have a dial tone.  

 

Mine does not have any patterns or indications why it's doing this.  No lights change colours.  Doesn't matter if it's a WIND or Rogers or Bell customer or whatnot.  No way of resetting anything to fix this. 

 

When I first got this modem, it was dropping calls left and right.... on every.  single.  call.  So I called tech support --- they "reset my network", we replaced the SIM card with a new one, we rebooted the modem, etc etc etc etc.  It doesn't seem to be dropping calls now, but I never know if my home phone is working or not ---- and we don't know until we notice the voicemail light lit up, hours later.  

 

Great.  At least the old modem worked, even though the beeping was a pain in the neck.  

Flag this to a Moderator
Message 3 of 15
1,492 Views
Former Moderator FidoManuel
Former Moderator

Re: ZTE WF720: Odd behavior when select callers go straight to voicemail

Thanks for the details!

 

I'll keep an eye for any update about the new modem. 

Cath will continue in PM with you. 

 

 



Flag this to a Moderator
Message 4 of 15
1,490 Views
I'm a Contributor Level 1 theperfectimage
I'm a Contributor Level 1

Re: ZTE WF720: Odd behavior when select callers go straight to voicemail

My account too shows name display as an added option and I do not get name display only number display.Have been a home customer 4 months and have the ZTE 720.How do I get the name display function properly as my account states that I have that option ?Any help appreciated ?

TIA

 

Flag this to a Moderator
Message 5 of 15
1,446 Views
Former Moderator FidoChristina
Former Moderator

Re: ZTE WF720: Odd behavior when select callers go straight to voicemail

Hey theperfectimage!

 

Thanks for posting and welcome to the community Smiley

 

It's really strange that name display shows up on your account on fido.ca . The Wireless Home Phone ZTE 720 actually isn't compatible with name display Sad

 

If you'd like to have the name display included, you would have to purchase the latest version of the modem - ZTE 721.

 

Don't hesitate if you need anything else!

 

 



Flag this to a Moderator
Message 6 of 15
1,442 Views
I'm a Contributor Level 1 theperfectimage
I'm a Contributor Level 1

Re: ZTE WF720: Odd behavior when select callers go straight to voicemail

Name display has been shown as an added option since Dec.4/15.So that will be including this new invoice 3 billing periods that I have not had name display option only number display.Very confusing for older person.

Flag this to a Moderator
Message 7 of 15
1,438 Views
Former Moderator FidoChristina
Former Moderator

Re: ZTE WF720: Odd behavior when select callers go straight to voicemail

I understand and thanks for letting us know!

 

I'll send you a private message so we can discuss further Smiley



Flag this to a Moderator
Message 8 of 15
1,437 Views
I'm a Contributor Level 2 gcrmt
I'm a Contributor Level 2

Re: ZTE WF720: Odd behavior when select callers go straight to voicemail

I'm also having this problem.  My parents are with Rogers home phone and often when they call me my phone doesn't ring (though their end does) and the call goes to voicemail.  Stupid thing is my phone doesn't indicate there is a voicemail either.  It was working before fine up to a few months ago.  Some calls get through and others don't.

Flag this to a Moderator
Message 9 of 15
1,386 Views
Moderator
Moderator

Re: ZTE WF720: Odd behavior when select callers go straight to voicemail

Hey @gcrmt and thank you for using the Community Smiley

 

Did you first try to reboot you Wireless Home Phone modem to see if it fixes the issue?

 

Let me know Smiley 

 

 



Flag this to a Moderator
Message 10 of 15
1,383 Views
I'm a Participant Level 2 PL27
I'm a Participant Level 2

Re: ZTE WF720: Odd behavior when select callers go straight to voicemail

Hi, I have the same problem starting recently. I called my Parent's ZTE home phone and it never ring, while I heard ringing at my end. There is no problem with any other phones (phone numbers) that call into this ZTE home phone to make it ring, but only my phone number. I have tried reboot their ZTE and still the same. I took the ZTE phone back to my place and test it. I noticed when I called, although the ZTE phone doesn't ring, at about the 7th "ring", the ZTE voice message light turns on to green, battery and signal lights turns orange (all briefly for about 1 second), and then the call get dis-connected. It looks as if the phone call gets forward into voicemail mode (we have de-activated voicemail feature). This never happen over 2 years until recently. Can anyone help on it? I read from another fido forum posting that disabling caller id feature by fido may help. Is it the case? Thanks.

Flag this to a Moderator
Message 11 of 15
843 Views
Former Moderator FidoManuel
Former Moderator

Re: ZTE WF720: Odd behavior when select callers go straight to voicemail

@PL27 Did you do the update on your WF720? Visit the link for some instructions, that might fix some problems you have Smiley 

Keep me updated on the results!



Flag this to a Moderator
Message 12 of 15
841 Views
I'm a Participant Level 2 PL27
I'm a Participant Level 2

Re: ZTE WF720: Odd behavior when select callers go straight to voicemail

Hi FidoManuel,

Thanks for quick reponse. The update link sent is for WF721, not WF720 that I have. Is there another update link for 720? Or other possible fix or thoughts? Thanks.

Flag this to a Moderator
Message 13 of 15
838 Views
I'm a Participant Level 2 PL27
I'm a Participant Level 2

Re: ZTE WF720: Odd behavior when select callers go straight to voicemail

I found the source of the problem. It was the "Name display" feature that somehow was added by Fido (at $0) to this wireless home phone account. Not sure why it got added. Probably this feature is not compatible with ZTE720 model causing some phone numbers call in but no ringing. I called fido to remove this feature (keep call display) and it fixed instantly the problem.

Flag this to a Moderator
Message 14 of 15
832 Views
Highlighted
Moderator
Moderator

Re: ZTE WF720: Odd behavior when select callers go straight to voicemail

Thanks for letting us know, PL27!



Flag this to a Moderator
Message 15 of 15
820 Views