Wifi Calling only = no SMS recieving

Wifi Calling only = no SMS recieving

Wifi Calling only = no SMS recieving

I'm a Participant Level 1

Wifi Calling only = no SMS recieving

iPhone 6s on 10.3.2. Been having this issue since a few carrier updates. If I have no service but have wifi, calls work fine and i can send SMS, but I cannot recieve SMS. Once i connect to Fido towers, the texts start coming in. I've tested with a few friends and by sending an sms to myself.
The problem can be reproduced by turning airplane mode on and wifi only. Send an sms to yourself and you will not recieve the sms!
Hope this can be fixed in a future carrier update by fido.



Former Moderator

Hey @Teddybearstand


Welcome to the Community! 


Thanks for reaching out about this! I'll send you a PM so we can look into this further. 

I'm a Participant Level 2

Why PM if the whole purpose of the community is for everybody to be aware?
I have the same problem with iOS 10.3.2 when I go abroad (Airplane mode) and I'd like to know as well if there's any solution for it yet.
I can send sms but can't receive any.
Please no personal message, keep it public for everyone to be informed.

Hello SunSeeker06,


  Welcome to the community!


  Just to add to FidoRayna's post above, this is a public forum and access to your account details requires verification of personal information.  After your account details are verified, the moderators can then access your account -- that's often why some issues are dealt with by PM.


  No one is trying to keep the solutions secret...


Hope this helps Smiley



I'm a Participant Level 2

Thanks for the update. Is there an eta on the fix? 

Hey @Mistertom


Are you now having issues with this?


I'm a Participant Level 2

That is correct. I'm not able to receive SMS over wifi. I can send them just fine and can place and receive calls over wifi. 

Let's have a look at that @Mistertom !


I'll send you a PM on here

I'm a Participant Level 2

I am having the same problem with wifi calling. Calls can be placed and received but only outgoing SMS works. Incoming text messages are not delivered over wifi and when I return to the cellular service area no texts are waiting. I have called fido support and have had my account refreshed but this has not rectified the problem. I'd really like to get it corrected as I'm only on the cell network every second week. Phone is a galaxy s7 and is up to date. I have also factory reset the phone. 

It's our pleasure Smiley @tommy44

Hey @SunSeeker06


We're all about sharing the knowledge and you're 100% right that this is what the Community is for. However, certain things require us to take a peek at the account and verify the  settings to make sure everything is well set-up. 


If you'd like us to take a look at your account to make sure everything is set-up properly we'll be more than happy to do so , let us know and we'll send you a PM! 

I'm a Participant Level 2

Thank you for the clarification Ranya.
Please do take a look at my account and let me know the outcome.
Your support is very much appreciated.

Hi @Mistertom and @SunSeeker06 


We are currently aware that certain customer's who're using Wi-Fi Calling can't receive SMS. We're working on fixing this as quickly as possible. 


Thanks! Very_Happy 

I'm a Participant Level 3

Hope they can rectify this problem quickly. I rely quite heavily on my wifi calling. Thank you for  your quick responses and help


Thanks again