WIFI won't turn off

WIFI won't turn off

WIFI won't turn off

unhappynewuser
I'm a Participant Level 3

WIFI won't turn off

Hello all,

 

i recently changed providers from B**L and have come across a problem i couldn't seem to find an awnser to online or in any forum.

Simply stated my wifi wont turn off. it tunrs on right after i turn it off.

just for fun i decided to try out the phone with the old B**L SIM card and what do you know....the wifi turns on and off whenever I want it too. No problems. Slide in the FIDO SIM card and can't turn off wifi.

Has anybody come across this problem? 

EXTRA INFO: Samsung S3, Was locked, now unlocked. Did a factory reset with no change in results.

 

any ideas??

 

 

 

11 REPLIES 11
zyx
I'm Qualified Level 2
I'm Qualified Level 2

Would this video solve your issue?

unhappynewuser
I'm a Participant Level 3

That opion isin't available.

Ive watched many videos the same as that one and I cant find one that originates from Canada. All that I found are ones from US. It seems that option is found in phones from providers in the US.

any other ideas?

 

@Community Smiley

Anyone would have an idea of what's happening to help our friend here?

 



It could be an app that is causing the problem.

 

or try this

 

Settings>More Settings>Mobile networks>Connections optimizer>Uncheck box that says "automatically select best mobile network"



unhappynewuser
I'm a Participant Level 3

After the factory reset, there wasn't any app other than the ones that were part of the original phone setup. This didn't happen when I first purchased the phone with the same default apps..

The optimizer option isin't available, It's not on my phone, I've looked high and low.

Thanks

lma
I'm a Participant Level 2
I'm a Participant Level 2

 

I had the same problem when I inserted a Roam Mobility SIM card (for Canadians travelling in the U.S.) into my phone.  The Wi-Fi would turn on even after I turn it off, and constantly search for Wi-Fi networks to connect to, eating up my battery in a few hours when it would normally last me 2 days. I read online somewhere that it might be the service provider making customers use Wi-Fi whenever possible to reduce the burden on their own network.  I never had a problem with Fido SIM cards in the same phone though, so if I were you, I might ask Fido for another SIM card to see if the problem persists.  I would also try your current SIM card and a new one (if you get it) on other smartphones (e.g. friends'); if the problem doesn't occur on other phones, it might just be some weird SIM card - phone chemistry going on that I don't know of.  My phone is an unlocked/never locked LG G2 mini from Asia.

unhappynewuser
I'm a Participant Level 3

Thanks  Ima,

 

i'm going to ask for a new SIM card.

When I called FIDO i was told that their SIM card has no control over a wifi connection. Samsung told me the same thing.

I don't believe that. Like you said, when you put in another SIM card the same problem occurred.

I'll get another card and test it on another phone and mine to eliminate the culprit.

somehow ......i think the problem will continue

 

Thanks again

Hey unhappynewuser, 

 

We'll send you a PM to help with the SIM card Smiley 

 

 



unhappynewuser
I'm a Participant Level 3

So.... I changed the SIM card and nothing has changed. I was given the SIM card for this model of phone with no change.

I do have the service code for my phone given to me by my previous provider. Perhaps the issue can be solved through the "sub settings" of the phone, settings not made availabe through the user interface of the phone by using this service code.

This was the method that I used to unlocked the phone as instructed by my previous provider. Might it be used to solve this problem?

 Hey @unhappynewuser.

 

Sorry to see you are still having trouble to turn off the WI-FI.

 

@Community: Anyone has an idea if going in the settings would help? 



unhappynewuser
I'm a Participant Level 3

any other ideas are still welcome