Unlocked Bell BB Storm always roaming with Fido SIM Card

Reply
Highlighted
I'm a Participant Level 1
I'm a Participant Level 1

Unlocked Bell BB Storm always roaming with Fido SIM Card

I just purhcased an unlocked BlackBerry Storm 9530 that used to be on the Bell network. I inserted my SIM card, got it on the Fido network and everything has been working fine; calls, SMS, BBM, emails, etc. I was wondering if it's normal that my phone always shows me roaming though. Does my phone think it's using the Bell network, because the phone clearly states its on the Fido network.

 

Also, why is the call center closed. I called Fido and they told me its closed, its 11AM on a friday FFS. Fido is going downhill...

 

 

 

Accepted Solution

Re: Unlocked Bell BB Storm always roaming with Fido SIM Card

Your half right, and half wrong.

Your SIM card is telling your phone to look for a home network with the ID of 302-370, but since your phone cant find such network, since its been de-commissioned, it however found 302-720, which is the rogers network ID, and IS allowed to use it, but since the ID's don;'t match, it shows ROAMING.

When fido brands its phones, they put a special fix in the software to eliminate this. but since this phone came from Bell, it wont have that in it.

Be sure to click likes for those who have helped you!
Click Accept as Solution for posts that have solved your issue(s).
View solution in context
Flag this to a Moderator
Message 1 of 19
8,485 Views
Highlighted
I'm a Contributor Level 1
I'm a Contributor Level 1

Re: Unlocked Bell BB Storm always roaming with Fido SIM Card

Hi guys, sorry to bump this topic, but it was one of the first to pop in Google, so I decided to ask my question in it to help out others too.

 

When you have an unlocked non-fido phone with a Fido SIM card, your phone says you're roaming because it isn't a fido phone with the special programming in it whuch makes it see the Rogers network 302-720 as being Fido network.

 

Now my question is, could this prevent receiving MMS by hazard?

 

I have my APN settings correctly configured, I can send MMS to anyone, but cannot receives any, I always get the "message not downloaded" SMS message instead.

 

My Fido SIM card is pretty old, it dates back from Microcell Solutions in 2003 before Rogers bought Fido, could this be part of the issue too? If I buy a new Fido SIM card today, will the new SIM card know that 302-720 is Fido network?

 

I guess Paolo would be the best suited to answer my questions.

 

Thanks in advance,

Phil

Flag this to a Moderator
Message 11 of 19
3,418 Views
Highlighted
Community Specialist
Community Specialist

Re: Unlocked Bell BB Storm always roaming with Fido SIM Card

Hi there Guizmo,

 

I recommend an isolation test. Insert your SIM into a different phone (Fido phone or another unlocked phone) and see if the issue persists. If it does, change the SIM card. If it's doesn't, the issue is with your phone (probably the settings)

 

You can do this in a Fido Store.

 

Let us know



Flag this to a Moderator
Message 12 of 19
3,395 Views
Highlighted
I'm an Expert Level 2
I'm an Expert Level 2

Re: Unlocked Bell BB Storm always roaming with Fido SIM Card

Hello Guizmo,  I would like to chime in and help out, I know for a fact many of the phones Ive owned have a setting in the MMS menu where you can allow MMS when Roaming.  Before when Fido used 302-370 as their network, you could turn this setting off and receive mms just fine,  now that all fido decomissioned its old  towers and all subscribers are on the 302-720 network (rogers) the phone is technically roaming, so you would have to allow this option to receive mms, even though you are on your home network, the phone doesnt know that.   So I do not know what is a hazard? but you would need to find the allow mms while roaming somewhere in the settings of this "hazard" and enable it and see if it helps.   otherwise if not, you might need to re-input the mms settings again or double check if theyre correct

Flag this to a Moderator
Message 13 of 19
3,390 Views
Highlighted
I'm a Contributor Level 1
I'm a Contributor Level 1

Re: Unlocked Bell BB Storm always roaming with Fido SIM Card

Thanks Stephane and Paolo.

 

I'll make the test that you recommend Stephane later this afternoon, I will keep you posted on the result.

 

@Paolo.

 

You're correct, since the phone thinks it's roaming, the Enable Data roaming must be enabled. I've found the setting and it was already turned on. I disabled and re-enabled it just in case. I did two tests with this settings.

 

1- When the setting is OFF, I cannot send nor receive MMS.

 

2- When the setting is ON, I can send MMS, but still cannot receive any.

 

As for the "hazard", I guess Google did not translate correctly what I met. By "by hazard" I meant "by any chances". Wink

 

I will make the test that Stephane suggested and come back to you, I've got one fido-locked phone and one fildo-unlocked phone somewhere in here.

Flag this to a Moderator
Message 14 of 19
3,386 Views
Highlighted
I'm a Contributor Level 1
I'm a Contributor Level 1

Re: Unlocked Bell BB Storm always roaming with Fido SIM Card

Ok, I've just tested with a Fido branded Sony Ericsson T303a unlocked phone and I do receive MMS. This phone runs Symbian and as two APN profiles. One is called Fido WAP and the other Fido MMS. Unfortunately Symbian doesn't show much configuration of those two.

 

My current phone is a manufacturer unlocked Sony Ericsson SK17a, it is running Android 4.0.4. This phone is compatible with Fido GSM and 3G network. The APN profile I have configured is as follow:

 

http://guizmo.biz/?attachment_id=1438

http://guizmo.biz/?attachment_id=1434

http://guizmo.biz/?attachment_id=1435

http://guizmo.biz/?attachment_id=1436

http://guizmo.biz/?attachment_id=1437

 

I also have another manufacturer unlocked Android phone but that is only compatible with Fido GSM network since the 3G band it uses are for european countries, but can't use it to test since the touchscreen is defective... This one is running version 2.0.1 of Android.

 

I do not have any data plan for 3G, but the Fido representative I spoke to on the phone told me that I didn't need any for MMS, so I guess this isn't the problem.

Flag this to a Moderator
Message 15 of 19
3,380 Views
Highlighted
I'm an Expert Level 2
I'm an Expert Level 2

Re: Unlocked Bell BB Storm always roaming with Fido SIM Card

ok i think we might be onto something here.

 

unlocked blackberries will need a bis connection (blackberry data or blackberry social or blackberry instant messaging or blackberry email) for the mms service book to be installed on the handset.  the mms service book contains all the mms server settings and on blackberries unfortunately can not be manually edited, and can only be pushed by the carrier to your handset with a valid subscription and is not guarenteed to work with non fido handsets.  if you happen to own a fido branded blackberry, chances are the service book will be installed on your handset already since the phone originated from fido, but if you use a third party blackberry, like an unlocked rogers or telus blackberry or other, the service book on your handset is from another carrrier so there is a chance for some mms issues.   since using a non-blackberry is out of fido's scope of support, they will recommend you try a fido branded handset to solve the problem.  hope this helps

Flag this to a Moderator
Message 16 of 19
3,065 Views
Highlighted
I'm a Contributor Level 1
I'm a Contributor Level 1

Re: Unlocked Bell BB Storm always roaming with Fido SIM Card

Thanks for the reply Paolo.

 

I do not own a BlackBerry, but an Android phone. I simply hijacked this thread because I though it was related to my issue since in an earlier post you mentionned that the Fido network was decommisionned and every non-fido phone were roaming.

 

Since my last reply, I've been busy figuring this problem out. I've ordered and replaced my touchscreen digitizer on my older android phone to test if the problem occured.

 

Unfortunately for me, it does.

 

So right now, I've only been suceful in sending and receiving MMS with a Fido phone running Symbian. Both of my Android phones will not download MMS, but will send them.

 

Just to clarify a few things.

 

Receiving MMS is free in Canada.

I do have an unlimited MMS option for sending them to a Canadian phone number.

I do NOT have a data plan.

 

I've tried different APN settings, and each time, I can send MMS, but cannot download them. No matter if I use wap.fido.ca, internet.fido.ca or fido-core-appl1.apn

 

Now I do receive sometimes text message from Fido saying that I've tried to access the Internet but that I need to have a valid data plan to access it. I do not know if this might be related, because when I did call Fido about my incoming MMS problem, the support guy did say that I didn't need a data plan to receive MMS. Beside, I can send MMS, so I must somehow have an Internet connection for that.

 

Would by any chances, incoming Internet access be blocked by default, but outgoing allowed in a Fido customer profile?

This is the only thing I can think of right now, somwhow there's a firewall preventing an incoming Internet connection to my phone. But strangely enough, when I use my old Symbian phone bought from Fido, I can browse the Web and receive MMS.

Might it be possible that somehow the incoming Internet connection be blocked for smartphones, but allowed for basic phones? And since it does work with my Fido "branded" basic phone, I don't see how the SIM card could be the problem.

I've been with Fido since 2003-2004, but never used MMS. I just lately been receiving tons of MMS message cannot download because I've got some friend now on Public Mobile with phones too stupid to cut long SMS to multiple SMS, they instead convert it to MMS and send it as a huge text message.

Flag this to a Moderator
Message 17 of 19
3,054 Views
Highlighted
I'm a Contributor Level 1
I'm a Contributor Level 1

Re: Unlocked Bell BB Storm always roaming with Fido SIM Card

Well I've finally solved my problem. Since this topic pop-up in the first Google results, even if you're looking for Android settings, I'll describe the problem and how I was able to fix it (three possible fixes).

 

I used to have a Microcell Solution SIM card that dated back when Fido was owned by Microcell and not by Rogers. With this SIM card, my phone was in roaming mode on the GSM network, since the SIM card was 2G/EDGE only.

 

After much googling, I found out that the conversations.apk, which is the default messaging application of Android, is set by default to not download/retreive MMS while roaming.

 

On most Samsung Android phones, there's a setting in the messaging application to allow MMS when roaming. On my two Sony Ericsson Android phones, this option was no where to be found. There's a Data roaming option under Android general Settings-Mobile network-Data roaming. This option must be enabled too and is available on every Android phones.

 

So I tried two other messaging application from the Google Play Store (formely Android Market). Handscent SMS and Go SMS. Both were able to receive MMS, because both have a settings to allow MMS when roaming. This "fix" is what I would recommend if you don't want to spend one penny to fix it and if you're not a technically advanced user.

 

The other fix I found, works if you have root access on your phone. So you must be a technically advanced user.

 

There's an .xml configuration file for the conversations.apk application located under "data/data/com.sonyericsson.conversations/shared_prefs/ . The file to edit is named com.sonyericsson.conversations_preferences.xml .

 

In this file you must edit the line

 

<boolean name="pref_key_mms_retrieval_during_roaming_visibility" value="false" />

 

You simply need to change the false value to true.

 

This will add the "MMS when roaming" option under settings in the default messaging application on any Sony Eircsson Android phones.

 

There's another option that might interest users texting in French, Spanish or other languages that use special characters. This option is called:

 

<boolean name="semc_pref_key_character_conversion_visibility" value="false" />

 

If you set to true this line, you'll see a new option under settings of the messaging application called "Cost saving". This option when enabled, simply convert any special characters like é to e, à to a, ç to c, so it sends out regular text. This will allow 160 characters SMS. Special characters uses up to 4 characters, which considerably diminish the size of a message you can send. This option is good for users without unlimited SMS.

 

There's also another line in there that might interest Android users running preview version of Android(actual version is Ice Cream Sandwich) like Froyo and Gingerbread. This line allows to prevent conversations.apk from converting long text message to MMS. By default, message longer than 3 SMS gets converted to MMS. You can set this value to up to 20. Great option if you do not have an unlimited MMS plan.

 

The line is:

 

<int name="semc_pref_key_mms_trigger_sms_segments" value="3" />

 

On Froyo and Gingerbread the default is 3, but on Ice Cream Sandwich it is already set to 20.

 

Anyways, once you've edited the file, you need to reboot your phone for the changes to take effect. It is very important that you do not open the messaging application before having rebooted the phone, otherwise the value you just entered will get overwrited.

 

Once rebooted, go into the settings of the messaging application and you should have the MMS when roaming, and the Cost saving options.

 

And finally I have found another fix. Buy a new Fido SIM card which cost 10$. With the 3G Fido SIM card, my cell does not detects that it is roaming, even if the 302-370 network is no longer active. With this SIM card, you do not need to have data roaming enabled nor MMS when roaming option.

 

I hope this might help other users with unlocked non-Fido Android phones with older SIM card like I used to have.

Flag this to a Moderator
Message 18 of 19
3,035 Views
Highlighted
I'm an Expert Level 2
I'm an Expert Level 2

Re: Unlocked Bell BB Storm always roaming with Fido SIM Card

Im glad i was able to offer some insight and to see that u solved the problem, i knew it was the roaming setting in the mms all along, hope this helps!
Flag this to a Moderator
Message 19 of 19
3,021 Views