Unable to log in to my account

Unable to log in to my account

Unable to log in to my account

forthebubbly47
I'm a Participant Level 1

Unable to log in to my account

Hello,

 

Ever since I switched from a prepaid to a monthly plan last month, I have been unable to log in to see my account. Every time I have tried it sends me to a blank page every time I go here: https://www.fido.ca/pages/#/my-account/overview. I have already spent half an hour on the phone for them to tell me that it's a website error and to try again later. I have been trying for the past two weeks! Please advise on what to do.

 

Also, I am very disappointed on two parts:

 

One: When I switched to my monthly plan, the man on the phone said the balance from my prepaid account would be transferred over as a credit on my first bill. I received my first bill and the credit was not included. After calling in, I was informed that it "should" be on next month's bill, not a promise or guarantee that it would be. I expected more reliable customer service from Fido.

 

Two: When I switched to my monthly plan, I was promised a $5 credit off the first six months. Sure enough, I received the first bill and it was not included. After calling in, the same person advised me that "sometimes" it takes a few months for the credit to kick in. I would have appreciated being told this information when I first signed up and it is very frustrating for someone who has been a customer with Fido for over 8 years now. Since you decided to get rid of Fido Dollars for most of us, there isn't much keeping me around as a loyal customer and when stuff like this happens, it's difficult not to move elsewhere. I would appreciate some assistance on these matters. Thank you.

 

 

 

5 REPLIES 5
FidoRachel
Former Moderator

Hey @forthebubbly47, welcome to the community! 

 

When going from prepaid to postpaid, your prepaid balance is applied on your first or second invoice.  

 

Are you referring to the migration credit? If so, it’s applied on your third invoice for the following 6 months as long as you stay on a plan that is eligible. 

 

Sorry if there was any confusion; don't worry, you'll receive the credits you were offered Smiley

 

I think the link you sent me is from a page in your account, right? I can't open it since I don't have your log in cerdentials. Do you get the same problem with a different browser? 

 



MidnightDream23
I'm a Participant Level 2

Thank you for responding to me, I appreciate it. This is Forthebubbly47; I'm having no luck with logging in as now when I tried to reply to this under that username, it won't let me log in and only asks me to register!

 

Okay, I was finally able to get to the log in screen but now a "Connect account" page comes up and it has a bunch of information to fill out - account number, name, postal code, etc. but once I fill it out, it says it doesn't match your records which makes no sense but I know the information is correct!

 

I thought maybe I had to register again but it won't let me because when I put in my e-mail address, it tells me it's already in use. Please help!

@MidnightDream23, are you having the same problem if you try with a different browser? You might need to clear your cache.

 

Let me know how it goes! 



MidnightDream23
I'm a Participant Level 2

I have tried logging on from my work computer, my laptop, and my tablet. They all give me the same problem (I even tried clearing the cache on all three). Now I was finally able to log in but it brings me to a "link account" page where I put in my account number, name, and postal code. I enter those in but it gives me a "Sorry, the information you’ve entered is not in our records." error, which makes no sense because the information has always been correct. I haven't changed my name and I haven't moved addresses. It is getting really frustrating! Please advise on how to continue.

I'll check it out @MidnightDream23, I'll send you a PM.