Throttling OpenVPN traffic

Throttling OpenVPN traffic

Throttling OpenVPN traffic

kia_sx
I'm a Participant Level 3

Throttling OpenVPN traffic

Today I noticed a problem connecting to my OpenVPN server running on my home router. I've used this same server, same configuration settings, same phone with same operating system in the past and it worked perfectly. Today however when I tried it I was able to connect to the server but for some reason only downloads were working but uploads were almost non-existent.

 

I contacted Fido by phone, actually spent all afternoon because I was transferred out or told that there is nothing that Fido can do multiple times, even though I kept calling back with more evidence that this is definitely a Fido problem. Here is what I have gathered so far:

 

  1. Using the APN on my phone: LTEMOBILE.APN, I am able to connect to my OPENVPN server on UDP port 1194, but I cannot get any uploads working from my phone. Seems like throttling is occuring. 
  2. Using the APN on my phone: Fido-core-appl1.apn, EVERYTHING WORKS. Although now I'm not getting LTE speeds, my OpenVPN connection works and uploads as well as downloads are working perfectly.

When I got home tonight I played around with my server settings and I finally got my vpn to work on the Fido LTE network. I had to switch to TCP port 443 (which is a port reserved for HTTPS traffic). All other UDP or TCP ports that I tried were not working. Going back to any UDP port made the problem with uploads from my phone start again. Therefore it is clear now that Fido is throttling, but the question is why? This was working fine up until last month when I switched to the new Fido Pulse plan. I mentioned this to one of the reps on the phone and they told me that there is nothing in my plan that would do this.

 

What is going on Fido?

 

Thanks

 

9 REPLIES 9
FidoTerry
Former Moderator

Welcome to the community @kia_sx!

 

We'll look into this and get back to you as soon as possible once we have an answer Smiley



kia_sx
I'm a Participant Level 3

Status update:

 

Tried again today and now it is working on the proper TCP port but UDP is not working. I am happy with this for now. It seems like it was some sort of network issue on Fido's side. My problem is that even after calling in to Fido and posting on this site, no one ever answered my concerns. 

 

If this was a network issue from the begining, then that's acceptable to me. What's not acceptable is how Fido handled this situation when I tried to reach out to them either by phone or on this forum. 

 

Very disapointed. 


@kia_sx wrote:

... My problem is that even after calling in to Fido and posting on this site, no one ever answered my concerns. 

 

If this was a network issue from the begining, then that's acceptable to me. What's not acceptable is how Fido handled this situation when I tried to reach out to them either by phone or on this forum. 

 

Very disapointed. 


Hello Kia_sk,

 

  Welcome to the community!

 

  I understand your frustrations at not getting an timely solution to your concerns. However, I hope you understand that not many people are as familiar with VPNs, TCPs or UDPs as you are. FidoTerry noted -- in a timely manner -- that they're looking into it and will respond once they have an answer. Since they're not as familiar with your particular issues, it will take a little while to sort out. Thinking that's not an acceptable answer is a little unreasonable.

 

Cheers


kia_sx
I'm a Participant Level 3


 


Since they're not as familiar with your particular issues, it will take a little while to sort out. Thinking that's not an acceptable answer is a little unreasonable.

I undertand this is a technical issue and not everyone has this knowledge or problem, which is why I asked multiple times on the phone and now on this community forum for technical support from someone at Fido who knows. I've had this issue since Wednesday (which is when I discovered it, could have been going on longer on the Fido network) and since then:

  1. I called to ask for technical support but was denied, hung up on twice and told to call these people instead: my router manufacturer, my phone manufacturer (LG Nexus 5) or go to a Fido store to show them my phone (as if they would know what to do there).
  2. No one on this forum has responded to me other than saying they will look into it.
  3. I filled out a complaint form from here: https://www.fido.ca/web/page/portal/Fido/Share_a_concern which clearly states "We’ll get back to you within 1 business day" I haven't recieved any response in over 3 business days. 
  4. I filled a complaint with last agent I spoke to in regards to the agent that hung up on me because I asked him to speak to someone else after I asked him what is the proper APN setting I should be using on my phone (he got aggressive with me and told me that he doesn't know what an APN is and that if I am playing with settings in my phone Fido is not responsible). I was told that a manager would get back to me in 1 business day to follow up on that complaint, I was never contacted back.

I have been a Fido customer for 13 years and I've never experienced this level of customer care before. All this to say that:


 


Thinking that's not an acceptable answer is a little unreasonable.

...it is reasonable to think this is not an acceptable answer. 

 

Thanks


@kia_sx wrote:

...

  1. No one on this forum has responded to me other than saying they will look into it....

Hello again,

 

  Have you considered that most of the members in this community are not technically inclined? The community isn't comprised of people from technical support. Most of us are Fido customers wishing to provide assistance where we can. There may be some members who do have a knowledge of your situation, but there is no guarantee they will visit the community on a regular basis. Even the moderators, who do monitor the forums regularly, wouldn't necessarily have the expertise required to provide a solution. As such, FidoTerry noted they'll get back to you once they have an answer. You will just have to give the technical team more time to sort out the details of your issue. 

 

Cheers


FidoTerry
Former Moderator

@kia_sx As @Cawtau mentioned, we may not have all answers immediately but we'll be glad to find the answer for you. It can take some time however so your patience and understanding is always appreciated.

 

That being said: I'm sorry to hear that someone hung up on you. That is not something we find acceptable. We'll be glad to send you a PM if you want us to talk about this. Smiley

 

 



kia_sx
I'm a Participant Level 3


That being said: I'm sorry to hear that someone hung up on you. That is not something we find acceptable. We'll be glad to send you a PM if you want us to talk about this. Smiley

 

 


Yes please send me a PM to talk about this. This is the only thing I've been trying to do for the last 4 days, get someone from Fido to contact me about my issues. 

 

I'm sorry if I caused any problems here. I thought this was a place to ask questions about Fido related matters. I know there is a community aspect to it (where non-Fido people can help others out, which is great if someone non-Fido knows the answer) but I assumed that Fido would be more involved with responses. I've tried to reach Fido privately (phone and complaints form) up to now, I was using this public forum as a last ditch effort to finally get help. Maybe I thought someone else was having the same issue as well. 

 

Thanks

FidoTerry
Former Moderator

You can definitely send us your concerns here and don't worry there was no problem created. I'll send you a PM in regards of your issue and update this thread when we have an answer for the VPN issue. Smiley



FidoMaria
Former Moderator

Hi @kia_sx!

 

We definitely don't want you to think that we're avoiding answering your concerns. We're looking into this and we'll get back to you as soon as we get more info.

 

Thanks for your patience. Smiley