Samsung phones are for the Chinese market

Samsung phones are for the Chinese market

Samsung phones are for the Chinese market

Bohdank
I'm a Participant Level 1

Samsung phones are for the Chinese market

I can't believe this but Fido is selling Samsung phones setup with firmware for the Chinese market. I changed my plan this weekend and ordered a S6 Edge.... Language choices, English, French and 3 oriental languages. I sent it back after support told me to call Samsung. Excuse me..Fido sold me the phone. So I thought maybe the S7...appears all the Samsung phones supplied by Fido all have Chinese firmware..... What, there are no Latinos in Montreal and through who are they getting their Samsung phones.... I am very pissed. 

 

 

2 REPLIES 2
Cawtau
Senior MVP

Hello Bohdank,

 

  Welcome to the community!

 

  The Samsung phones sold by Fido/Rogers (as well as the rest of the Canadian mobile service providers) are the Canadian versions of those models. They are intended for the Canadian market. The two official languages of Canada are English and French. The Korean and Chinese languages are included because Samsung is a Korean company. It's rather ignorant to expect a company not to include their own language(s) in their product versions.

 

  There are undoubtedly many other languages spoken/read in Canada. However, there are only two official languages. If you require a specific language, you might consider obtaining a global version of those phones. They may include the language you're looking for. If you do decide on a global version, you would need to also consider whether it has all of the compatible bands/frequencies (see here).

 

  Alternatively, some other phone manufacturers include more diverse language options.

 

  Hope this helps Smiley

 

Cheers 


FidoTerry
Former Moderator

Welcome to the community @Bohdank! Smiley

 

Depending on the phone you choose, there's different languages you can choose from on the phone settings. It's possible you accidentally selected Chinese so the phone language was set to Chinese. You can change the language afterwards however. 

 

You can select the Settings Icon once you swipe down on the top right hand corner and then Language and Input ( You will see a A icon ) then Language ( first choice ) and finally you can select English.

 

Hope this helps! Smiley