Samsung Galaxy S7 Edge Connectivity Issues

Reply
Highlighted
I'm a Participant Level 3
I'm a Participant Level 3

Samsung Galaxy S7 Edge Connectivity Issues

Hello,

 

I've had my Samsung Galaxy S7 Edge for about 2 weeks now and everything seemed fine for the first week.

The 2nd week I noticed that my 4G/LTE drops and I'm left with just the full signal bars. When this happens I lose all data and phone connections. I cannot place a call, text, or go onto the internet. In order to solve this I've been restarting the phone and it seems to work for a few hours and then does the same thing. (Quicker fix is to reset network settings). Although restarting the phone and resetting network settings makes the phone work, it is only a temporary fix and I don't believe I should be doing this that often.

I've already replaced the sim card today for $10.50 hoping it was just the sim. It worked for a few hours longer and now it is doing the same thing.

 

To Fido,

Is there currently an issue with the network?

 

Thanks!

 

 

 

Accepted Solution

Re: Samsung Galaxy S7 Edge Connectivity Issues

Hey everyone,

 

The Android 7.0 update is now live for the S7 & S7 Edge.

 

Along with Nougat, this update includes a fix for the connectivity issues reported in this thread. Thank you, everyone, for taking the time to flag this and provide your examples. 

 

Please let us know how it goes!

 

View solution in context
Flag this to a Moderator
Message 1 of 244
58,345 Views
Highlighted
I'm a Contributor Level 1
I'm a Contributor Level 1

Re: Samsung Galaxy S7 Edge Connectivity Issues

I'm also having this issue. It's extremely inconvienent. If anyone has found any resolution, can you please let me know? 

Flag this to a Moderator
Message 31 of 244
3,073 Views
Highlighted
I'm a Contributor Level 1
I'm a Contributor Level 1

Re: Samsung Galaxy S7 Edge Connectivity Issues

Still having issues here as well. Lately it has been more often as well, it seems. I feel like it is location based, perhaps triggered when reception is lost (going through a tunnel/elevator shaft/area with minimal reception), and has issue regaining 4G/LTE service. I have tried the sim card in my old Galaxy S4 and everything is working fine there. Ran that for a few days in the same environment to rule that out as a factor. I've also tried a full device wipe, with no resolution. After googling for answers, I have only come across Fido-related reports for this specific issue, leading me to believe it lies within the service provider. I sincerely hope this is resolved in the near future, perhaps a fix is in motion?

Flag this to a Moderator
Message 32 of 244
3,066 Views
Highlighted
Moderator
Moderator

Re: Samsung Galaxy S7 Edge Connectivity Issues

Hey @s7ePhone and @TraJiK

 

I'll send you both a PM shortly. Smiley 

 

 



Flag this to a Moderator
Message 33 of 244
3,063 Views
Highlighted
I'm a Participant Level 3
I'm a Participant Level 3

Re: Samsung Galaxy S7 Edge Connectivity Issues

Hi,

 

I have a S6 edge + unlocked since january and i have the same kind of issues.

The sims was put on a iphone 5s and works perfectly

 

I made a factory reset and it seem to be working a little bit better now, but i still have a lot of connectivity issues.

I often got 5 or 4 bars but i can't make a call and send SMS or go on the internet. It tells me that there is no network but i see 4g or LTE at the top.

 

I just tried to set to GSM only but haven't seen any changes for now.

 

I have a coworker with a S6 on Rogers and he doesn't have this issue. I though fido and rogers were using the same network.

 

Thanks.

Flag this to a Moderator
Message 34 of 244
3,028 Views
Highlighted
Former Moderator
Former Moderator

Re: Samsung Galaxy S7 Edge Connectivity Issues

We have the same network!

Keep me updated now that it's on GSM only, make sure to reboot the phone and test it as it for 24 hours. 

 

 



Flag this to a Moderator
Message 35 of 244
3,026 Views
Highlighted
I'm a Contributor Level 1
I'm a Contributor Level 1

Re: Samsung Galaxy S7 Edge Connectivity Issues

Hi

I was having same issues .

I have exchanged my phone 3 times for another device.

Yesterday I got my 3rd device so far so good.

Its was very annoying for the phone to loose the network and have to constantly have to reboot.

The phone would work on the GSM network but very slow .

Will keep you posted.

Thanks Mrm

Flag this to a Moderator
Message 36 of 244
3,014 Views
Highlighted
I'm a Contributor Level 1
I'm a Contributor Level 1

Re: Samsung Galaxy S7 Edge Connectivity Issues

I had the same issues. Had to replace my device 3 times and sent device to SAMSUNG  for repair.

When I received device back from Samsung nothing had changed. Still had same issues.

Finally after replacing the device for the 3rd time everything is working properly.

I have had this issue since the beginning of April.

Hope this info helps you 

Mrm

 

Flag this to a Moderator
Message 37 of 244
2,985 Views
Highlighted
I'm a Contributor Level 1
I'm a Contributor Level 1

Re: Samsung Galaxy S7 Edge Connectivity Issues

Hi

My recommendation replace your device.

i had to replace my device 3 times

Hope this info helps you.

Mrm

Flag this to a Moderator
Message 38 of 244
2,984 Views
Highlighted
I'm a Contributor Level 1
I'm a Contributor Level 1

Re: Samsung Galaxy S7 Edge Connectivity Issues

I really don't see replacing the device multiple times in hopes of getting a working one the real solution here. I certainly hope I don't need to go through the device exchange process to get a chance at a "fixed" device, and I can't imagine Fido is ready and willing to go through the same. Seems to me it's not a hardware issue, but I suppose you are the only one reporting with a working device after having the issue on prior devices...

 

Hope the Fido team is able to come to a conclusion on this problem soon. If not, lets hope the exchange process is expidited for us all.  

Flag this to a Moderator
Message 39 of 244
2,978 Views
Highlighted
I'm a Participant Level 3
I'm a Participant Level 3

Re: Samsung Galaxy S7 Edge Connectivity Issues

I am having the same issues. Data drops randomly, after a reboot it works fine for a bit then back to the connectivity issues. I have done factory reset twice, changed to new SIM card. I didn't restore any settings the second time just to make sure it wasnt a conflict with apps, kept it factory, same thing it worked for a bit then didnt. called fido couple of times regular troubleshooting and of course any troubleshooting usually involves a power off so it would work for a bit then again. this is very frustrating! it cant be a defective phone if so many people with exact problem. 

 

if anyone gets any fix pleaaaase post! 

 

btw its an S7 not edge. 

Flag this to a Moderator
Message 40 of 244
2,961 Views