Samsung Galaxy S4 - problem detecting SIM card

Reply
Highlighted
I'm a Contributor Level 1 smasry1
I'm a Contributor Level 1

Samsung Galaxy S4 - problem detecting SIM card

I have a Samsung Galaxy S4 that is 2 and a half years old, I used it until last december without any problems.

I gave the S4 to my son and it worked fine until last week. It started saying that no SIM card is inserted. My son would restart the phone and it would work for a while then suddenly the message that no SIM is inserted comes up. The only way to get it back is by restarting the phone and occasionnaly that does not work as well.

My son's SIM is one of the new universal SIMs that can fit in any phone (nano, micro or regular size)

 

I know that the phone is OK for the following reason:

1- When I put my SIM in it, there is no problem, I also tried my daughter's SIM in the phone, also without any problems. (both my SIM and my daugher's are micro SIMs that we got before FIDO started sending the new universal SIMs that can me used with the diffrent SIM size readers).

 

I also know that my son's SIM is OK for the following reason:

2- If I put my son's SIM in my phone (LG G4) or in my daughter's phone (Nokia Lumia 625) it works fine without any errors.

 

I made a test with a brand new universal SIM in the Samsung S4, and it did not detect the SIM so one would reach the conclusion that the problem is from the new unviersal SIMs, yet the one my son has worked for 3 months without any problems until last week.

 

Does anybody knows how to fix this problem?

 

Thanks

 

 

 

Flag this to a Moderator
Message 1 of 16
2,566 Views
Highlighted
Former Moderator FidoMaria
Former Moderator

Re: Samsung Galaxy S4 - problem detecting SIM card

@smasry1 Let us know how it goes. Smiley

 

Can you clarify what you mean by switching the registered phone numbers to the SIMs?



Flag this to a Moderator
Message 11 of 16
1,079 Views
Highlighted

Re: Samsung Galaxy S4 - problem detecting SIM card

Sorry but you can not switch numbers between SIM cards. Just go to any Fido store and get them to replace the SIM that is not working.



Flag this to a Moderator
Message 12 of 16
1,079 Views
Highlighted
I'm a Contributor Level 1 smasry1
I'm a Contributor Level 1

Re: Samsung Galaxy S4 - problem detecting SIM card

I meant if FIDO can register my phone number to my son's SIM and his phone number to my current SIM since my current SIM works without any problems on the S4, while his current SIM works on my phone. (I am guessing it can be done because when I got my current phone, an LG G4, I received it with a new SIM card but I had an Issue activating it so when I called FIDO they were able to manualy associate my phone number to the new SIM. But at the end they associated back to my old SIM)

Flag this to a Moderator
Message 13 of 16
1,060 Views
Highlighted
Former Moderator FidoCatherine
Former Moderator

Re: Samsung Galaxy S4 - problem detecting SIM card

Hey Smasry1

 

I think I understand what you mean 😃

 

To clarify; each SIM card is "linked" to the phone number itself. 

 

1 SIM card can't be used for 2 different phone numbers. 

 

You can change phone models with the same card, but not the phone number linked to it. 

 

I hope this helps clarify 😃

 

 



Flag this to a Moderator
Message 14 of 16
1,051 Views
Highlighted
I'm a Contributor Level 1 smasry1
I'm a Contributor Level 1

Re: Samsung Galaxy S4 - problem detecting SIM card

Thank you all for your help.

 

The SIM started working again on its own with the Samsung S4, without me doing anything. It has been working for 4 full days so far.

 

Not sure if it will happen again, will have to wait and see.

 

Thank you.

Flag this to a Moderator
Message 15 of 16
1,018 Views
Highlighted
I'm a Participant Level 1 The-RyU
I'm a Participant Level 1

Re: Samsung Galaxy S4 - problem detecting SIM card

I'm having this exact issue. Galaxy S4 unlocked. If I insert an older(yet lte) sim, it works fine, yet if I use the newer multi-sized sim, The phone will not detect it, both sims have been tested on multiple phones to be sound. Cache cleared and factory restored more than once to no avail. Also, similarly, the newer sim used to work until about a week ago. I'm considering replacing the sim port, but I"m doubting it will fix the problem. Anyone else experiencing this?
Flag this to a Moderator
Message 16 of 16
694 Views