Samsung Galaxy S4 - problem detecting SIM card

Samsung Galaxy S4 - problem detecting SIM card

Samsung Galaxy S4 - problem detecting SIM card

smasry1
I'm a Contributor Level 1

Samsung Galaxy S4 - problem detecting SIM card

I have a Samsung Galaxy S4 that is 2 and a half years old, I used it until last december without any problems.

I gave the S4 to my son and it worked fine until last week. It started saying that no SIM card is inserted. My son would restart the phone and it would work for a while then suddenly the message that no SIM is inserted comes up. The only way to get it back is by restarting the phone and occasionnaly that does not work as well.

My son's SIM is one of the new universal SIMs that can fit in any phone (nano, micro or regular size)

 

I know that the phone is OK for the following reason:

1- When I put my SIM in it, there is no problem, I also tried my daughter's SIM in the phone, also without any problems. (both my SIM and my daugher's are micro SIMs that we got before FIDO started sending the new universal SIMs that can me used with the diffrent SIM size readers).

 

I also know that my son's SIM is OK for the following reason:

2- If I put my son's SIM in my phone (LG G4) or in my daughter's phone (Nokia Lumia 625) it works fine without any errors.

 

I made a test with a brand new universal SIM in the Samsung S4, and it did not detect the SIM so one would reach the conclusion that the problem is from the new unviersal SIMs, yet the one my son has worked for 3 months without any problems until last week.

 

Does anybody knows how to fix this problem?

 

Thanks

 

 

 

15 REPLIES 15
FidoAmanda
Former Moderator

Hey smasry1!

 

Welcome to the Community!

 

That's definitely strange. The S4 doesn't have any known issues with reading Multi-SIM cards. 

 

Have you tried doing a factory reset?

 

Let us know!

 

 



smasry1
I'm a Contributor Level 1

Hello and thanks for your reply.

 

I tried almost everything except the factory reset, which I am hesitant to do for 2 reasons:

 

- This particular SIM (the FIDO universal sim) worked without problems on this particular phone for the last 3 months.

- Other SIMs work fine on the phone except another universal SIM (the same as the one we have a problem with).

- I have done some research and read that a few users who had similiar issues did a factory reset but it did not fix the problem.

 

I do not know what suddenly changed. I might give the factory reset a try but I have my doubts

 

Thanks

You said the SIM that is not workng is a new SIM I guess its an LTE SIM? The other SIM that you said worked when you tried it is it a LTE SIM? if it was not a LTE SIM try puting the phone on GSM only and see if it works. If it still does not I would suggest getting a new SIM card and see if that works before taking further steps.

 

Also did you clear the cache the way I suggested? Do it like 3 times i've seen success after doing it 3 times.



smasry1
I'm a Contributor Level 1

Hi,

 

Both SIMs are LTE. I cleared the cache 2 or 3 times without any change. One SIM works and the other does not (on the S4). I will try to clear it again, then maybe do a factory reset if that does not work but I don't have high hopes for the reset.

 

Maybe switching the regestered phone numbers to the SIMs would work if it can be done!

 

Thanks for your help.

Sorry but you can not switch numbers between SIM cards. Just go to any Fido store and get them to replace the SIM that is not working.



@smasry1 Let us know how it goes. Smiley

 

Can you clarify what you mean by switching the registered phone numbers to the SIMs?



smasry1
I'm a Contributor Level 1

I meant if FIDO can register my phone number to my son's SIM and his phone number to my current SIM since my current SIM works without any problems on the S4, while his current SIM works on my phone. (I am guessing it can be done because when I got my current phone, an LG G4, I received it with a new SIM card but I had an Issue activating it so when I called FIDO they were able to manualy associate my phone number to the new SIM. But at the end they associated back to my old SIM)

Hey Smasry1

 

I think I understand what you mean 😃

 

To clarify; each SIM card is "linked" to the phone number itself. 

 

1 SIM card can't be used for 2 different phone numbers. 

 

You can change phone models with the same card, but not the phone number linked to it. 

 

I hope this helps clarify 😃

 

 



smasry1
I'm a Contributor Level 1

Thank you all for your help.

 

The SIM started working again on its own with the Samsung S4, without me doing anything. It has been working for 4 full days so far.

 

Not sure if it will happen again, will have to wait and see.

 

Thank you.

The-RyU
I'm a Participant Level 1

I'm having this exact issue. Galaxy S4 unlocked. If I insert an older(yet lte) sim, it works fine, yet if I use the newer multi-sized sim, The phone will not detect it, both sims have been tested on multiple phones to be sound. Cache cleared and factory restored more than once to no avail. Also, similarly, the newer sim used to work until about a week ago. I'm considering replacing the sim port, but I"m doubting it will fix the problem. Anyone else experiencing this?

Hi @smasry1 Do you have a SIM PIN setup? Some people reported having this issue because of the SIM lock so if you have one try removing it.

 

If that did not work try clearing the cache partition.

 

1. Shut down the phone. Boot into recovery mode by holding down the on button and the volume up button at the same time, then releasing the on button when a message appears in the top left corner of the screen about recovery mode. Keep holding down the volume up button until it goes into recovery mode.

 

2. Run the option to clear the cache. Then restart the phone normally.



smasry1
I'm a Contributor Level 1

Hello,

 

Thank you for your response. We have no SIM PIN setup.

I did clear the cache twice already and it does not fix the problem. Again, If I switch the SIM, two other SIMs work without problem in the phone. The only thing I did not try is a factory reset but I have seen many people that said it does not fix the problem either.

 

Thank.

Hey @smasry1

You tried other SIMs but have you tried to update your own SIMcard on the account altogether?



smasry1
I'm a Contributor Level 1

Hello

 

Thank you for your response.

 

The SIM card in question is a fairly new one that we got last August.

I did get a new one 2 months ago for another phone but it also does not work on this specific phone. Both cards are the new universal one.

 

 

Thanks

That's definitely odd then!

I'll go ahead and send you a PM to check things out!

Talk to you soon.