Samsung Galaxy Nexus MMS inconsistant

Samsung Galaxy Nexus MMS inconsistant

Samsung Galaxy Nexus MMS inconsistant

SOLVED
I'm a Contributor Level 1

Samsung Galaxy Nexus MMS inconsistant

My Galaxy Nexus phone has intermittent problems receiving MMS messages. They often just sit there saying "downloading" but never come in.

I also have to sometimes cancel outgoing MMS messages because they sit there saying "sending' but don't go. When I cancel and try again they go right away. 

I have spoken to Fido who told me to call Samsung who told me to go back to the store, who told me to call Fido! 

Can someone help? 

 

 

 

Accepted Solution

Re: Samsung Galaxy Nexus MMS inconsistent

Solved by I'm a Contributor Level 1 pamstec

The trick seems to be to leave the setting to manual download for MMS. I still have to push the download button more than once on most photos coming in, but they do finally arrive. 

Thank you for your help. 

View solution in context
14 REPLIES 14
Fido Employee
Fido Employee

Hey everyone!

Although this thread is quite old, I'd like to update it since I came across it. Another quick tip to help toward the MMS sending/receiving: disable your Wi-Fi before using MMS. Sometimes the Wi-Fi connection is overlapping our connection and will cause a bug in the MMS application preventing it from working properly. Keep in mind that this can happens even if there is no Wi-Fi network in the area: if Wi-Fi is on, the phone will keep scanning to find a connection so make sure that it is disable.

Hope it helps!



Former Moderator

Hey pamstec!

Here are some things I'd suggest that you look out for:

- Make sure that data is ON within your phone's settings. You will not be charged for using data while sending / receiving MMS, but it needs to be ON for them to go through.
- If you ever contacted us to have data or MMS blocked on your account, contact us again to have the restrictions removed.
- Make sure that your APN settings include the MMS APN settings as well. You may find a list of APN settings in our Smartphones board, first thread at the top.
- Try to reset the settings on your phone. It's possible that a setting was changed by accident causing the issue.
- Delete as many things as you can from the phone to make some space. It's possible that you cannot download the MMS because the phone's memory is full.

I hope that this will help in resolving your issue. Should you still experience difficulties, I invite you to contact our technical support team at 1-888-481-3436 from any other phone than your Fido device.

Let us know!


I'm a Contributor Level 1

Thank you for your response. 

My Data is turned on

I have never had it blocked

I checked the APN settings and they seem to be fine- but I don't understand how I can receive and send sometimes and not others. What setting would cause that?

I have a ton of available memory 

I spent over an hour on the phone today with the "techinical support" who told me everything looked fine at their end - she also suggested I reset my phone but she was unable to tell me exactly how to do that. When I asked if I could not speak with a technician who was familiar with the Galaxy Nexus she told me she was not allowed to refer me to the tech department until she had exhausted all efforts to resolve the problem. She then told me she had made some changes and that I should get a text message within an hour or so; that I should then try to receive a picture again and see if it worked. If that did not solve the problem then I should reset my phone, lose all my data and apps and start agin from the beginning. After 2 months of problems with this phone, and the poor service from Fido I am regreting making the change from Telus. 

Any further suggestions would be most appreciated. 

 

I'm a Participant Level 2

My Galaxy Nexus has the same issue, I usally have to send the same photo twice to get it to go out.

And recieving is just random.. Sometimes it works. other times it doesn't..


This issue also happens on the Rogers network..

 

Quick solution is to disable 3G network.

And don't hate on FIDO, not they're fault Rogers can't seem to keep up with big boys :manlol:

I'm a Contributor Level 1

Thank you for your response Mark. It is helpful to know that it is not just my phone. I went into my mobile network settings and ticked the box for "use only 2G networks". (is that what you meant?) I will let you know how it works out. 

I'm a Contributor Level 1

Changing the network setting to 2G did not solve the problem. I now have 2 more photos sitting there "downloading" but not coming in. sigh


@pamstec wrote:

Changing the network setting to 2G did not solve the problem. I now have 2 more photos sitting there "downloading" but not coming in. sigh


Hey pamstec,

 

I've got a suggestion, although I'm not sure it will solve your problem. 

 

I'd suggest creating a separate APN for MMS. You can go to wireless & networks settings > mobile network settings > Access Point Names > tap the menu button, then New APN. Enter the following for MMS:

Name:  fido mms

APN:  mms.fido.ca

MMSC:  http://mms.fido.ca

MMS proxy:  205.151.011.013

APN type:  mms

 

For your primary APN, I'd suggest removing the MMSC, MMS proxy and port. 

 

Let us know how it goes.



I'm a Contributor Level 1

Well, the last suggestion did not work, BUT in trying it I noticed that the default mms proxy setting was missing the "0" in the last 2 points. (i.e.. 205.151.11.13 instead of 205.151.011.013)

When I changed that a message that was hung up downloading came in right away, and one that was hung up going out was sent. Fingers crossed that this is the solution and I will have consistent MMS service from now on. 

I will do some more testing tomorrow and post the result.

Thank you everyone for your ideas. 

I'm a Contributor Level 1

Should have known that was too easy - getting the same "downloading" message on a MMS coming in (or not) today. 


@ Community: Has anyone experienced this with a Galaxy Nexus? How were you able to get it fixed?


I'm a Participant Level 2

I'm experiencing the exact same thing. I followed all the instructions and created a new APN and followed all your suggestions.

 

I called Fido customer service earlier and they just told me to restart my phone and take the battery and the SIM card out for a moment. It didn't solve anything.

I'm a Participant Level 2

Okay I found a way to recover the pictures that haven't been downloaded: 

 

Check in your app's settings,

disable auto retrieve (under MMS)

find the picture

Hit download

 

and there you have it!

I'm a Contributor Level 1

Well, I had to try hitting the download button 2 times - it timed out the first time - and the picture came in!!! I will see how it goes in the future. Thanks for your post. Let me know if it continues to work for you.

I'm a Contributor Level 1

The trick seems to be to leave the setting to manual download for MMS. I still have to push the download button more than once on most photos coming in, but they do finally arrive. 

Thank you for your help.