S6: Wi-Fi calling is enabled but no longer working since Android 7.0

S6: Wi-Fi calling is enabled but no longer working since Android 7.0

S6: Wi-Fi calling is enabled but no longer working since Android 7.0

hhkjhgkjgghggh
I'm a Participant Level 2

S6: Wi-Fi calling is enabled but no longer working since Android 7.0

Ever since the update to Android 7.0, I have had the Wi-Fi calling feature enabled but it never does anything anymore.

 

I have it set to prefer Wi-Fi calling over using the network. When on Wi-fi, the icon never shows up on the status bar and all calls just go through the mobile network. My office has terrible reception and Wi-Fi calling was such a helpful feature, now I'm back to dropped or entirely missed calls.

 

I've tried rebooting the phone, dropping in and out of wifi or toggling airplane mode on and off. Nothing seems to make the feature turn on. I've tried updating the contact information. Nothing seems to work. 

 

3 REPLIES 3
KAPABLE-K
MVP

Hello @hhkjhgkjgghggh welcome to the community!

 

You can try a few steps to see if it will solve your problem.

1. Try clearing the cache partition ( this can be done by going to settings then storage and you should see the cache partition in there)

2. Try disabling the WiFi calling then enable it again.

3. Last resort is doing a factory reset.



hhkjhgkjgghggh
I'm a Participant Level 2

I finally broke down and did the complete reset this weekend. Sadly the problem persists as it did before.

 

Everthing in the settings menu's indicates it's enabled and prefering wi-fi. It just never actually activates or uses wi-fi calling when I'm on wi-fi. It's a real shame, Nougat improved many things but I get so many dropped calls now.

Hey @community

 

Anyone has an idea to help our friend @hhkjhgkjgghggh ?