S6 Edge Issues

S6 Edge Issues

S6 Edge Issues

I'm a Participant Level 3

S6 Edge Issues


So this past week I've been having problems with my s6 edge.

1) I'm like 1 minute into my call with someone and the call would drop.
2) It usually takes me 2-3 tries before I can dial out.
3) For 2 days, I wasn't able to receive any calls or texts. I called Fido, was told it may be that my SIM was damaged. I went and got a new one but still, at times no calls can go through (texted it with a different phone)
4) LTE rarely works.. Constantly on 4G and I can assure you that before this whole problem, LTE was always working.

I have updated to the latest update.. And honestly, racking my brain due to this phone and Fido.

Help, anyone? Since I called last time and was told they really didn't know what the issue was........




I'm a Participant Level 1

I am experiencing the exact same issue. I no longer get LTE service and drops to 4G. Even with 4G connection I can't make call outs, get access to the Internet or receive calls. When I do, they last for 2 minutes at most. I really need some. I can't even call fido to troubleshoot!

Hey johnny_khan99!


 Is this happening everywhere or only in a specific location? Does the same thing happen when you try your SIM card in another phone?


What version of the software are you running?  


Let us know!

I'm a Participant Level 2



I just got a S6 Edge+ and the exact same thing is happening.


Have you guys found a fix yet?


Did a factory reset, even called in to have an operator "reset the network" for me with no luck.


I've tried different APN settingsagain without luck... which one do you recommend?


If the problem is specific to Fido unfortunately there would be no choice but to call it quits Sad


The phone was working fine apparently with Videotron before he sold it to me, I've unlocked it successfully to use with Fido.


Please help! 

Good morning @leanman!


Welcome to the Community!


Did you notice that those problem happens when you are connected to a Wi-Fi network?

If yes, could you disable Wi-Fi--->reboot your phone and test it as it for a few hours. 

Let me know if that changed anything. 



I'm a Participant Level 2

I've tried all that, problem persists.


Just saw your PM, keep me updated with the results!

I'm a Contributor Level 2

Hi, I am also having the same issue for the last 4 days on my Galaxy S6.

When I make a call or answer a call I can only hear the first few words that are said and then it goes blank. I cannot hear the person on the other end of the line and they cannot hear me.

I have also noticed that my network is constantly switching from LTE to 4G. It's happening in multiple places for me.

I am also missing calls. The phone doesn't ring, but when I check my phone I see that I have a missed call.

Hey @yolo22


Can you test it out on GSM and see if you get the same issues hearing the other person on the line?


Let us know. Smiley 


I'm a Participant Level 3

Hi there @FidoAlyson, it happens pretty much everywhere. I'd have a strong connection to the Internet for like a minute and then it'd die completely.. Then after a bit more, go back to normal. Or if I'm in the middle of a call, a few minutes in and it'd drop. Then I'd have to dial back a few more times before the call connects again... Never used to happen before.

@AdamBeast, yes I know. I went to the Fido store and the lady there had switched my Network mode, but the issues still occurred.

I see, have you installed the newest updates? 


More info can be found here: http://forums.fido.ca/t5/forums/forumtopicpage/board-id/Smartphones/thread-id/25172


@Mm12345 I'll send you a private message so we can take a closer look into this.


Talk to you soon! Smiley

I'm a Participant Level 3

Hmm.. I did a factory reset last night and unfortunately am still experiencing the same problems..

I was told by a friend that works at a mobile shop that Fido / Rogers are upgrading their cell towers..? Can anyone confirm? Seems like only I'm having these issues lol. Might have to leave Fido cause dropped calls and whatnot aren't fun.. Sad

We definitely wouldn't want to see you go @Mm12345!

Can you let us know if this happens everywhere or only in specific areas? 

I'm a Participant Level 3

Zero modifications to it... I'm not tech savvy so modifications of any kind lose me haha..

Honestly, factory reset is the last move I'd like to make.

I've spoken to two other friends on the Fido & Rogers network and I've been told it's a network problem... But seems like other than the two of them and I, no one else is having such a problem..

I would recommend doing the factory reset you can backup the phone using smart switch.


If you know anyone else with a s6 that is not having issues try borrowing it and put your sim in and see if you still experience the same problem. If you don't then it could be hardware problems.

I'm a Participant Level 3

Hello! Yes, even with my LTE off I'm having the same issues..

I just want to verify, if you see '4G' on your phone, it doesn't mean LTE is turned off. 

You need go to Settings -> More Networks -> Mobile networks -> Network Mode , and please change it to "GSM/HSPA auto" instead of "GSM/HSPA/LTE auto" in order to turn off LTE completely. 


Did you do any modifications to the phone or is it still stock? Did you try a factory rest to see if it fix the problem?


Hey Mm12345 and welcome to the Community.

Are you having the same issues when your LTE is off?


@1234Com: Anyone with a Samsung Galaxy Edge has suggestions to help witht his?