Roaming on Pelee Island?

Roaming on Pelee Island?

Roaming on Pelee Island?

SOLVED
angelFrog
I'm a Participant Level 2

Roaming on Pelee Island?

Hello,

 

I'm visiting Pelee island and have the tablet data plan. When I arrived I received a text describing US roaming rates, although I'm still in Canada. Data has been working fine, and I don't see any indication of roaming charges on my usage page, but I'm still concerned I might get hit with a huge bill next month. My tablet says FIDO in the status bar.

 

Is there anything I'm missing?

 

Thanks!

Accepted Solution

Re: Roaming on Pelee Island?

Solved by Former Moderator FidoCatherine

Hi there @angelFrog

 

Thanks for reaching out to the Community!

 

It sounds like while on Pelee island, your tablet connected to a Fido partner (roaming) network. That would explain why you received a text message detailing the regular roaming rates of voice, text and data of the country or area being visited. 

 

Considering Pelee Island is (obviously) surrounded by water and also happens to be incredibly close to the USA borders, to be honest, I'm not really surprised that your device may have connected to a USA tower instead.

 

When your device is roaming, you'll notice an "R" symbol at the top of your screen. 

 

To avoid any connection while roaming, you can turn Roaming Off directly from your tablet's settings. 

 

I'd love to help with that Smiley

 

Can you tell me which Tablet you're using?

 

View solution in context
4 REPLIES 4
Cawtau
Senior MVP

Hello angelFrog,

 

  Welcome to the community!

 

  Just to add to the above, Pelee island is rather close to the US border so it is very possible your device might pick up some of their signals. That would explain why you received the text describing US roaming rates.

 

  However, there is only one Rogers cellular tower on the island (see here). Depending on your location on the island, your device might also connect to extended coverage (Fido-EXT). Using data on the extended network does require roaming data to be enabled

 

  I understand the concern regarding connecting and roaming on the US networks. You might consider manually selecting the Fido network when you're visiting the island. If you're visiting a part of the island without proper Fido/Rogers signal, you can then manually select Fido-EXT.

 

Have a great trip!

 

Hope this helps Smiley

 

Cheers


FidoCatherine
Former Moderator

Hi there @angelFrog

 

Thanks for reaching out to the Community!

 

It sounds like while on Pelee island, your tablet connected to a Fido partner (roaming) network. That would explain why you received a text message detailing the regular roaming rates of voice, text and data of the country or area being visited. 

 

Considering Pelee Island is (obviously) surrounded by water and also happens to be incredibly close to the USA borders, to be honest, I'm not really surprised that your device may have connected to a USA tower instead.

 

When your device is roaming, you'll notice an "R" symbol at the top of your screen. 

 

To avoid any connection while roaming, you can turn Roaming Off directly from your tablet's settings. 

 

I'd love to help with that Smiley

 

Can you tell me which Tablet you're using?

 



angelFrog
I'm a Participant Level 2

Hi,

 

When you mentioned I could turn off data roaming, I found it in settings and it was already turned off, so everything should be good.

 

Just in case though, it's an LG G Pad III 8.0, and I found Data Roaming under Wireless Networks->More->Mobile Networks.

 

Thank you Smiley 

Thanks for the update, angelFrog!