Request Fido LTE Set up for Blu Pure XR Unlocked phone

Request Fido LTE Set up for Blu Pure XR Unlocked phone

Request Fido LTE Set up for Blu Pure XR Unlocked phone

SOLVED
Delan
I'm a Participant Level 2

Request Fido LTE Set up for Blu Pure XR Unlocked phone

Hello everyone,

 

I would like some advise for setup the Fido LTE network for my new Blu Pure XR phone. somehow I tried all different type of methods still the phone only capable of connecting to 3G or HSPA+. any suggestions/helps would be highly appreciate. Below are the information about the phone.

 

Frequencies Supports: GSM/HSPA/LTE 

2G bands GSM 850/900/1800/1900/- Dual Sims

3G bands/HSDPA 850/1700(AWS)/1900/2100

4G bands LTE 2(1900), 4(1700/2100), 7(2600)

 

2G bands GSM 850 / 900 / 1800 / 1900 - SIM 1 & SIM 2
3G bands HSDPA 850 / 1700(AWS) / 1900 / 2100
4G bands LTE band 2(1900), 4(1700/2100), 7(2600)

 

 

my current network typemy current network typesomehow the phone does not detect the LTE networksomehow the phone does not detect the LTE network

 

Best Regards,

Delan

 

 

 

 

 

Accepted Solution

Re: Request Fido LTE Set up for Blu Pure XR Unlocked phone

Solved by Former Moderator FidoMaria

Hi @Delan & welcome to the Community! Smiley

 

Your phone seems to be compatible with our LTE network (you can check out our requirements here). Keep in mind though that LTE at 1700/2100 MHz on Band 4 may not necessarily be available on all towers.

 

That said, have you made sure that your APN settings were set up correctly? You can check out our settings here.

 

Hope this helps!

View solution in context
11 REPLIES 11
Delan
I'm a Participant Level 2

Thank you for all your feedback to:Cawtau,FidoMar & KAPABL for help me look into my Blu phone connectivity issue.

 

Unfortunately, I tried out all the methods and tips you guys mentioned still no luck for the LTE detection at all, there are two Rogers LTE tower near my house with the matching frequencies as you guys said the phone should be able to connect to LTE network not just the AWS Frequency 4(1700/2100),  but also the band 7(2600) which i heard Fido use this the most. My previous phone the LG G4 have no problem connect to LTE maybe because I bought the phone from Fido?

 

I guess this particular unlocked version of Blu pure XR just not work in our Canadian LTE network. I bought it from amazon and it support all the US carriers. =/ anyways Thank you so much for looking into this for me. I'm very appreciate for your time and effort =).

 

 

Best Regards,

Delan

i3kc
I'm a Contributor Level 1

I'm in the same boat.

 

I have a BLU Life XL and can't seem to connect to LTE.

 

I am connecting to 4G Network, but not 4G LTE.  I've also tried the suggested options, but still can't get it to work.  Has anyone resolved the issue?

FidoJessica
Former Moderator

Hey @i3kc!

 

I wanted to know if you were able by any chance to test your Sim card into another phone and see if you were able to connect to the LTE network ?

 

 



i3kc
I'm a Contributor Level 1

Hi!

 

I connected it to a iPad and got LTE.  I've tried it with a Asus Zenfone and although it supports Band 7, I can't get LTE (There is a tower with Band 7 really close to where I am).

 

This is a Tablet SIM if it makes any difference?

i3kc
I'm a Contributor Level 1

I did some digging, apparently some phone companies don't use the "LTE" badging.  In the case of the Zenfone, "4G" = "LTE".  If I am wrong, please correct me.

Hey @i3kc

 

LTE is the fastest network we have available. Maximum speeds depend on the combination of the network spectrum and technical specifications of the device used. It is possible that the device switches from LTE to 4G occasionally but you should still be able to connect to our LTE network if the following requirements are met. 

 

- LTE SIM card

 

- Subscribed to a plan with an LTE enabled Data option.

 

- LTE enabled device. Our network frequency bands are:


700 MHz on Band 17
1700/2100 MHz on Band 4
2600 MHz on Band 7

 

- Using the service within the LTE coverage which you can check out right here

 

Can you try resetting the device to its factory settings and configuring the unlocked phone with the parameters found here

 

Let us know if it works out! Smiley 

 



i3kc
I'm a Contributor Level 1

I sent my BLU phone back to Amazon.  But for my ASUS Zenfone 3, I figured out the issue.  

 

As posted on another thread: 

 

"I had a similar issue with my ASUS Zenfone 3. If you type
*#*#4636#*#* in dialler key pad, you'll get access to "Device information". From there, you can confirm your "Network type". It should confirm that you are on the "LTE".

As your phone is made for an "international" market, the connection icon will show "4G". "LTE" is a North American marketing term as the rest of the world uses "4G" to signify "LTE" network. As such, You'll mainly see the "LTE" icons on phones made for our domestic market."

 

This was a bit of deduction on my end.  I put is a SIM from another carrier with LTE into the Zenfone and it also showed 4G.  I checked the Network Type and confirmed it was LTE band.

 

Both the Fido SIM and the SIM from the other carrier show 4G on the ASUS while showing LTE on the iPad and Blackberry.

 

I think this all comes down to how the Phone manufacturer set the icon display (4G vs LTE).  4G  = LTE on "International Phones".

Hey @i3kc

 

Thank you for sharing what you found! Very_Happy 

 

 



Cawtau
Senior MVP

Hello Delan,

 

  Welcome to the community!

 

  Is your phone unable to detect LTE everywhere or only at certain locations? Had you been able to use LTE on a different phone in your area previously? As FidoMaria noted, coverage depends on the bands/frequencies of your surrounding cellular towers as not all towers use all of the bands/frequencies. You can get an idea of where the cellular towers and their associated bands/frequencies here

 

  I could be mistaken, but I don't believe the issue would be with your APN settings. Your phone should be able to at least detect the LTE network regardless. The APN settings would allow you to connect to the network properly once detected. For some reason, your phone is not detecting LTE at all -- even on extended coverage (Fido-EXT). I understand you have already set your Preferred Network to 2G/3G/4G/4G LTE. You might consider accessing the phone's information using android codes like this community user had to do here to properly set the preferred network. 

 

  Have you tried to enable roaming data? I'm not sure where the intended market for that phone is located. Some phones from abroad think they are roaming even though they are using a local SIM. Again, I'm not sure if enabling roaming data will solve your issue since it doesn't even detect LTE.

 

  Another possibility is that there might be an issue with the phone's connectivity itself: 

 

      ...Something else that bothered me was the connectivity. In places that I get a strong WiFi signal on my other devices, the Pure XR had weak or no signal. Same with mobile networks — on both T-Mobile and Cricket (AT&T), I had pretty serious issues with connecting to LTE, maintaining cell signal, or placing calls reliably... ~ taken from here.

 

  I understand they refer to US mobile providers and it's possible the reviewer had a faulty phone. However, it's something to consider...

 

  Hope this helps Smiley

 

Cheers 


KAPABLE-K
MVP

@Delan Check your APN settings it should be setup for LTE.

 

APN: ltemobile.apn

Username: <not set>

Password: <not set>

Authentication type: <not set>

Proxy: <not set>

Port: <not set>

MMSC: http://mms.fido.ca

MMS proxy : 205.151.11.13

MMS port : 80

MCC: 302
MNC: 370

APN type: default,mms

 

For full details on how to configure an unlock phone see here.



FidoMaria
Former Moderator

Hi @Delan & welcome to the Community! Smiley

 

Your phone seems to be compatible with our LTE network (you can check out our requirements here). Keep in mind though that LTE at 1700/2100 MHz on Band 4 may not necessarily be available on all towers.

 

That said, have you made sure that your APN settings were set up correctly? You can check out our settings here.

 

Hope this helps!