Problem connecting my new Fido account to profile

Problem connecting my new Fido account to profile

Problem connecting my new Fido account to profile

evaq
I'm a Participant Level 2

Problem connecting my new Fido account to profile

Hi,

 

I just got a 2 new postpaid Fido accounts (for my niece and nephew) yesterday under my account. However, I have an existing prepaid account that's a little over a year old that is also active.

 

When I tried to create a fido.ca profile for the new postpaid accounts, I received an error message saying "Sorry, the information you’ve entered is not in our records." It's been over 24 hours since the I got the phones, so I don't think it's a data/information lag. I'm assuming that part of the problem is due to the fact that all 3 accounts (2 prepaid and 1 postpaid) were all created and registered with the same email. Which didn't seem to be a problem in the store when I signed up for the new accounts...but it IS a problem when I try to create/add those 2 new post paid accounts to my existing fido.ca profile.

 

Does anyone have any insight or know how I can get this resolved? Any help would be appreciated.

 

Thank you!

3 REPLIES 3
evaq
I'm a Participant Level 2

Thanks! I'll reach out to @FidoSolutions.
mm15
I'm a Contributor Level 1

Not to hijack your post.... but I am having the same issue with my new Fido account I got yesterday. I input my information, and it says it's not on record. 

 

Maybe it takes time? 

FidoRachel
Former Moderator

Hey, we'd have to access the accounts to see what's going on. Don't hesitate to send us a message on Facebook and Twitter so we can look into this Smiley