No internet connection

No internet connection

No internet connection

Nngo2k
I'm a Contributor Level 2

No internet connection

Hi

I was watching netflix and youtube no problems. Suddenly the internet stopped working.

Every time I try to open my browser it asks me to log on to the Hitron modem.

I have rebooted the modem and my computer several times but it didnt resolve the issue

 

 

9 REPLIES 9
peachcedar
I'm a Participant Level 1

I had same problem. Called fido on friday when it happened to have fixed..now monday and still no internet or call to say it has been fixed.

Hey peachcedar!

 

Welcome to the Community!

Can you give me more details about the problem you are experiencing?

Di you try to reboot the modem? Which lights are ON? Are you getting an error message when trying to browse online?



Nngo2k
I'm a Contributor Level 2

Fido customer service vs competitor

Fido: called at 9am, rep was very understanding and didnt make me plug, unplug, reboot. By 1pm problem was resolved.

Competitor: opened a ticket in October, insists that the issue was my laptop when it was clear that bandwidth was ok during day time and dropped to 1mbps during peak hours consistently. No follow up, but offered a 20% discount.

December: opened another ticket for the same problem, asks me to submit speedtest, which I did. No follow up. Claimed they never received it. Sent results a second time. They agreed to send a technician. Tech never showed or called. I followed up again. They said that my speedtest had too many opened connections therefore it didnt meet the requirement and they didnt send anyone. I insisted that they dispatched someone. Which they eventually did but didnt give me a heads, so the tech showed up when I was at work. Fortunately someone was home. However the low bandwidth issue was left unresolved.


I will stay with Fido as long as I continue to get excellent customer service!

I'm totally doing back-flips celebrations here after reading that compliment @Nngo2k! ( Ok, maybe not physically but in my mind I am, haha ). Very_Happy

Thanks so much on sharing your love with us. Tongue



Nngo2k
I'm a Contributor Level 2

Uplink and downlink are there

There's no WAN IP address

Hey @Nngo2k 

Welcome to the Community! 

If you have already tried to reboot the modem, your next step will be to get a hold of our internet tech support team.

You can reach them at 1-888-236-3436



Nngo2k
I'm a Contributor Level 2

I did a soft and hard reboot. Factory reset. Still no connection

I would suggest you get the modem replaced.

 

Edit: What lights can you see on the modem



KAPABLE-K
MVP

Try login into the modem and set it up back maybe it got reset due to an update that did not take correct. If it won't work it could be a deffective modem and you should get it replaced.