My Account App (Wifi) issues

My Account App (Wifi) issues

My Account App (Wifi) issues

I'm a Participant Level 3

My Account App (Wifi) issues

Skim over the forum, it's great to know that My Account App could finally works with Wifi (a long time demand).

It looks like there are still some bugs need to be fixed.


Here I would report two issues against the update-to-date version: 2.3 on Android.


  1. Unable to "Pay Bill".
  2. Take forever to "Think". (Login)
  3. No "Exit" and/or "Logout" to exit the application.


Reproduce steps:

  1. Turn on Airplane mode (disable modem connection).
  2. Turn on Wifi (use only Wifi network)
  3. Launch Fido "My Account" app
    • Issue 2: It often takes forever to "Think". After minutes, I finally force to stop the app in the setting.
  4. Login account
  5. Browse the bill, and hit the [Pay Bill] yellow button.
    • Issue 1: It says unable to find a data connection (Guess it still try to use phone's connection, instead of Network over Wifi).
  6. Hanging there, I could only open the setting > App > Running: to close the My Account app. (issue 3).


Hope this would help the developer to figure out what's going on more efficiently.





Former Moderator

Hey Alamy! 


Thanks for the feedback! 


Have you tried to uninstall and re-install the app? 



I'm a Participant Level 3

It's Fido's phone, not my own "open" phone.

As it's a internal app (comes with the ROM, rootfs), it does not allow you to uninstall completely, but just "un-install all the updates" back to factory version, then re-install the "Update".


I had done it couple of times before (as other's suggestion). And I had just spent sometime to un-install and re-install again, and it does not work.


Please advice

if it (My Account) has newer version that solved the problem.

Or if the problem is at server side, that the IT has find the root-cause and fix it.


I believe as I had provided the reproduced steps, Fido's engineer should be able to reproduce the problem very easily and figure out the problem (it takes time to trace).


If the problem is not reproduce-able, maybe we could check other scenerio (like network, network settings, ...etc) to narrow down the problem.




I'm a Participant Level 3

Sorry about my previous reply a bit panic.


Something just poped up into my mind about the "payment" problem once manged to got logged in.

From the history of this application (used to be not able to connect through Wifi).


I doubt there were some code checking if the connection is through Data plan before.

As of newer version, it removed the restriction (or use other API).
But there are still some left somewhere, hence it could not complete the action as there is no Data plan connection (Airplan mode).


* I'm not familiar with Android App coding, but the author should know what I'm talking about 😛




Former Moderator

Thanks for those details @Alamy!


I'll forward the information to the team in charge of the App. We are still working on some features for our App, you'll encounter some bugs.


Let me know if there's anything I can help you with.