LTE not working on new plan

LTE not working on new plan

LTE not working on new plan

SOLVED
anjp11
I'm a Participant Level 3

LTE not working on new plan

Hello,
I just switched to fido from Virgin and am having problems getting LTE data to work. I'm using an unlocked LG G3.

I've read around the forums, saw this http://forums.fido.ca/t5/forums/forumtopicpage/board-id/NonTechnical/thread-id/20239, tried BOTH the fido-core and ltemobile APNs but it's not working.

I am getting data, just 4G at about 16 MBps. I know my phone works with LTE as ive been using it with Virgin for over a year. I have entered and reentered the APN settings. I have enables the radio button. It always defaults to 4G. I am in an LTE zone and my wife, who switched at the same time, has LTE working on her iPhone6.

Is it possible in this day and age I was given a non-LTE micro sim?

 

 

 

Accepted Solution

Re: LTE not working on new plan

Solved by I'm a Participant Level 3 anjp11
Thanks for your replies everyone. LTE wasn't working last night but seems to have fixed itself when I woke up this morning.
Maybe it had to register itself on the network or something. Any way, it's working now. Cheers!
View solution in context
6 REPLIES 6
Cawtau
Senior MVP


@anjp11 wrote:
Hello,
I just switched to fido from Virgin and am having problems getting LTE data to work. I'm using an unlocked LG G3.

I've read around the forums, saw this http://forums.fido.ca/t5/forums/forumtopicpage/board-id/NonTechnical/thread-id/20239, tried BOTH the fido-core and ltemobile APNs but it's not working.

I am getting data, just 4G at about 16 MBps. I know my phone works with LTE as ive been using it with Virgin for over a year. I have entered and reentered the APN settings. I have enables the radio button. It always defaults to 4G. I am in an LTE zone and my wife, who switched at the same time, has LTE working on her iPhone6.

Is it possible in this day and age I was given a non-LTE micro sim?

Hello Anjp11,

 

  Welcome to the community!

 

  For the moment, I'll assume you switched from Virgin Mobile Canada (VMC) and your phone was purchased from them. If true, then your phone would have (at least some) compatible LTE bands/frequencies since VMC uses the Bell network and their LTE band/frequencies are the same.

 

  Have you tried ltemobile.apn in either all lowercase or all capitals? One community member recently noted that their phone would only recognise all lowercase while that other thread you posted in suggested all capitals might work.

 

  Have you tried to turn on roaming data? In some instances, phones not on their original networks think they are roaming even though it's using a local SIM.

 

  Are you unable to get LTE everywhere or only at some locations? The antennae differ in strength between phones. It's possible that you're in an area with weak LTE signal and your wife's phone is better able to get reception at low signal levels. You can get an idea of the cellular towers in your area using mapping sites like here.

 

 As @FidoMegan suggested, it might be worth trying a different SIM (known to be LTE). If you do not have access to a different SIM, you might consider taking your phone into a Fido location and asking them to test one of their LTE SIMs. You also might consider testing your SIM in one of their phones to determine whether your SIM is indeed LTE capable.

 

  Does your phone actually note LTE? I understand 4G often denotes H+ and you're concerned about only getting 16 MBps. However, actual LTE download speeds would vary depending on which band/frequency your phone was connected to (see here), as well as signal strength, network congestion, other apps using data, etc. Could your phone be labelling LTE as 4G? You can confirm which network your phone is connected to in your phone's status settings under mobile network type. 

 

  Hope some of this helps Smiley

 

Cheers


anjp11
I'm a Participant Level 3

Thanks for your replies everyone. LTE wasn't working last night but seems to have fixed itself when I woke up this morning.
Maybe it had to register itself on the network or something. Any way, it's working now. Cheers!

Awesome!

 

Glad to hear it's working for you! Smiley

 

Cheers


VINCE_99
I'm a Contributor Level 1

Hi @anjp11

 

 I think you can see your phone's bands here : http://www.gsmarena.com/search.php3 

 



Dial the code 3845#*855#

Scroll down to LTE Only

Click Modem Settings

Click RAT Selection

Pick your choice.

See if you get a LTE connection if you do power off the phone wait 15 seconds then power it on again.


FidoMegan
Former Moderator

Hey anjp11! 

 

Welcome to the Community! Smiley 

 

Do you know what the LTE frequencies your phone uses? Also, do you have another phone you can try your SIM card in? You would also need a LTE data plan. 

 

Let us know!