LG G4 - H812 - LTE Issue

LG G4 - H812 - LTE Issue

LG G4 - H812 - LTE Issue

SOLVED
XMG
I'm a Participant Level 3
I'm a Participant Level 3

LG G4 - H812 - LTE Issue

Hi everyone,

 

I have been having a really weird issue with my phone and I couldn't seems to figured out what's wrong with it.

 

To start off, I bought my phone off kijiji and it was locked to Koodo. The model is H-812 and it's currently running Marshmallow. When I checked the Network band it fully supported Fido network. I unlocked the phone and it was working fine with Fido network however it seems that it stays on 3G most of the time with rarely if not at all going to LTE (it's been a few days since it got stuck at 3G now).

 

So far these are all the steps that I have tried with no luck;

 

- I followed all the instruction from http://www.fido.ca/consumer/content/configure-unlocked-device-guide (I made sure my device is compatible with the Fido network, and I set up my APN setting correctly)

- I don't think it's the coverage because it doesn't matter where I'm at (I work and live in central area of Ottawa or even downtown Toronto), I still get 3G all day long.

- Preffered Network set to GSM/WCDMA/LTE auto

- Rebooting the device

- Airplane mode cycle

- Factory reset

 

A few things to note:

 

- I don't think it's the SIM card because before I switched my phone it was working fine

- I managed to get into the hidden menu and I could switch the LTE back on by manually selecting the LTE BAND that FIDO use and I will get LTE speed, however as soon as I did this I won't be able to receive a phone call. I could make a phone call but as soon as the call goes through the network switches back to 3G and it stays there even after hanging up the phone call!

- Through the hidden menu I could changed the preferred network to LTE only but by doing this I won't be able to make/receive phone call as they can only be made through 3G network

 

So it seems that my phone doesn't switch back automatically to LTE network as soon as it switched to 3G network.

 

At this time I can only think of a few cause;

 

- Koodo phone doesn't work really well with Fido network?

- Defective phone or software?

- Should I try to buy a new SIM card anyway just to make sure?

 

Does anyone ever have this issue with their phone?

 

Please help & thanks in advanced!

 

 

Accepted Solution

Re: LG G4 - H812 - LTE Issue

Solved by I'm a Participant Level 3 XMG

Just want to give everyone an update on this issue.

 

So I tried putting on my SIM card on a different phone and I was able to get LTE no problem so that rules out the issue from the SIM card. I then decided to do another fatory reset just to see if I'll get my LTE back and it seems that I do get it back.

 

It took a day before I lost it again. So I manually set the modem through the hidden menu to GSM only and then back to GSM/WDCMA/LTE auto and I managed to get it working again. It's been two days now and I still have my LTE on auto switch.

 

So for now it seems that the issue is kind of fixed but I'll let you know if the issue comes back.

 

Thanks!

View solution in context
11 REPLIES 11
Cawtau
Senior MVP

Hello XMG,

 

  Welcome to the community!

 

  Sorry to hear you are having issues with your phone. You are correct in that the H812 is the Canadian version and fully compatible with the Fido/Rogers network.

 


@XMG wrote:

 

...

So far these are all the steps that I have tried with no luck;

 

- I followed all the instruction from http://www.fido.ca/consumer/content/configure-unlocked-device-guide (I made sure my device is compatible with the Fido network, and I set up my APN setting correctly)

...


  I understand you set up your APN correctly, however just to be sure, since the device is LTE-capable, it should be using ltemobile.apn

 


@XMG wrote:

 

...

 

A few things to note:

 

- I don't think it's the SIM card because before I switched my phone it was working fine

- I managed to get into the hidden menu and I could switch the LTE back on by manually selecting the LTE BAND that FIDO use and I will get LTE speed, however as soon as I did this I won't be able to receive a phone call. I could make a phone call but as soon as the call goes through the network switches back to 3G and it stays there even after hanging up the phone call!

- Through the hidden menu I could changed the preferred network to LTE only but by doing this I won't be able to make/receive phone call as they can only be made through 3G network

 ...


  As FidoChristina noted, you might consider testing your SIM in a different phone again to make sure it has not become damaged during the transfer. You also might consider going to a Fido location and asking to try a different SIM in your phone.

 

  When you changed the preferred network to LTE, is the connection stable? I understand it isn't a solution because you wouldn't be able to make/receive calls. However, is the phone able to hold a LTE connection?

 


@XMG wrote:

 

...So it seems that my phone doesn't switch back automatically to LTE network as soon as it switched to 3G network.

 

At this time I can only think of a few cause;

 

- Koodo phone doesn't work really well with Fido network?

- Defective phone or software?

- Should I try to buy a new SIM card anyway just to make sure?

 ...


  I agree, it sounds like the phone is having issues switching networks. However, I cannot think of any reasons why a Koodo phone wouldn't play nice on the Fido network. The phone does work on the network -- when you select LTE manually. That suggests to me that it is an issue with the phone itself. However, it would be interesting to go to Telus and ask to try one of their SIMs to see if the issue persists.

 

Hope some of this helps Smiley

 

Cheers

 

 

 


XMG
I'm a Participant Level 3
I'm a Participant Level 3

Hello,

 

Thanks for the reply.

 

1. Yes I've set the APN to LTEMOBILE.APN and I've deleted and re-created it numerous times

2. I even tried to enable data roaming but still no luck

3. When I changed it to LTE only, I have a very strong signal and hold it very well. I've had it for a good couple hours until one of my friend told me that they can't call me (that's how I found it phone call doesn't work in LTE only network)

 

Switching back manually between GSM & LTE seems very inconvenient Sad

 

Like I've mentioned the only thing I haven't try is getting a new SIM card. I will try that later and see if that fix the issue.

XMG
I'm a Participant Level 3
I'm a Participant Level 3

Just want to give everyone an update on this issue.

 

So I tried putting on my SIM card on a different phone and I was able to get LTE no problem so that rules out the issue from the SIM card. I then decided to do another fatory reset just to see if I'll get my LTE back and it seems that I do get it back.

 

It took a day before I lost it again. So I manually set the modem through the hidden menu to GSM only and then back to GSM/WDCMA/LTE auto and I managed to get it working again. It's been two days now and I still have my LTE on auto switch.

 

So for now it seems that the issue is kind of fixed but I'll let you know if the issue comes back.

 

Thanks!

Thanks for keeping us posted @XMG 

 

Glad to hear it's working! 😃 

 

If anyone else has any further insight on this, thanks for taking the time to share!

 

 



tuanssj
I'm a Participant Level 2

I just renew my contract and got LG G4, i'm in the same situation where you can txt but can't make phone call

 

if i switch to my old nexus 5 it working great on LTE


@tuanssj wrote:

I just renew my contract and got LG G4, i'm in the same situation where you can txt but can't make phone call

 

if i switch to my old nexus 5 it working great on LTE


Hello Tuanssj,

 

  Welcome to the community!

 

  As @XMG noted above, it would be important to ensure that your network mode is set to GSM/UMTS(WCDMA)/LTE. With the exception of voLTE, voice calls can only be made on the 2G and/or '3G' networks (GSM and/or UMTS/WCDMA, respectively). 

 

  All phones -- your old Nexus 5 included -- will standby with a data connection (LTE if available). However, once a call has been initiated or received, the phone will fall back to '3G' or 2G circuit-switching for calls. If your phone has been set to LTE only, it will not be able to switch networks for calls.

 

  Do you get LTE with your new phone? Not necessarily connected to your current issue, but have you verified the phone is using the correct APN? Since the phone is LTE-capable, it should be using ltemobile.apn. You can verify the correct settings here.

 

Hope this helps Smiley

 

Cheers

 


tuanssj
I'm a Participant Level 2

the phone is one auto mode as mention, i have also check all APN was set originally

 

the phone can't make or receive call, so when i switch back to nexus 5, it a same issue but after reset the network it working again without any problem, while with the LG G4 if you reset the network it work for few hour then return back to same issue, i have make a appoint to swap for the same phone, hope it working properly this time

XMG
I'm a Participant Level 3
I'm a Participant Level 3

Since it does the same with your Nexus 5, then there might be a chance your SIM card is deffective.

 

One thing that you can try is go to hidden menu type *#546368#*812# on your dialer --> Field Test --> Modem Settings --> RAT selection --> GSM only.

 

See if you can make call after doing that

XMG
I'm a Participant Level 3
I'm a Participant Level 3

Hmm a bit different than my issue. I was able to make call & text & data but just not getting LTE.

 

Can you receive a phone call? Do you see LTE or 2G/3G sign on top? or just full bars?

 

Did you set mobile network to GSM/WCDMA/LTE auto?

Hi there @tuanssj

 

Thanks for reaching out! I'd love to help with this. 

 

Can you try a manual network search, from your phone's network settings? 

 

Are you also able to see if the phone's connected to the Fido network? 😃

 

I'd also suggest to try a full power-cycle, to see if this helps!

 

Here's how: 

- Turn the phone Off

- Remove the SIM card

- Insert the SIM card back in

- Turn the phone back On 

 

Thanks for letting me know!



FidoChristina
Former Moderator

Hey @XMG,

 

Welcome to the community!

 

Have you tried testing your SIM in another phone just to be sure? I know you mentionned it was working fine before the phone switch but it might be a good idea to see if everything is up and running right now.

 

Any other ideas, @community ?