Grand Prime won't play video

Grand Prime won't play video

Grand Prime won't play video

madhatter
I'm a Participant Level 2

Grand Prime won't play video

Model SM-G530W, Ver 5.1.1. Won't playback any video even that recorded by phone. Tried every possible solution on the net. 

 

 

4 REPLIES 4
KAPABLE-K
MVP

Hi @madhatter

 

What happens when you try to play a video?

What video playback app do you have installed?

 

Update: Try uninstalling Google+ (or its updates), then reinstalling it, this seems to solve the problem for many users.



madhatter
I'm a Participant Level 2

Tried the G+ re-install. Usually I get the flag" can't play video". Have used VLC player, and others with no success. When I try to playback video recorded on the phone it plays for 3 seconds then skips a few frames and quits.

Thanks for the update!

Have you tried to reset the phone?(Make sure to take a back up before doing so)

Anyone else from @Community can help?



RESET YOUR APP PREFENCES

The first step to fixing the problem is to force your Samsung device to forget its 'default apps'.

A default app is one which opens automatically when you perform a certain action – like howChrome opens when you tap on an internet link, or your camera opens when you want to attach a photo to a message.

Resetting these preferences won't destroy any data on your phone, but the next time you click a link or add an attachment, you may be asked which app to use as your new default! Follow these steps to clear your app preferences:

cant play video galaxy core primevideo error samsung primecant play video in galleryfix video problems
  1. Open your apps list and find the Settings icon. Tap on it to view your full list of settings.
  2. Scroll down this settings list until you find Application Manager, then tap on it to continue.
  3. You will now see a list of your installed apps and games. Tap the three dots in the top-right corner of the screen to make a menu appear.
  4. There are two options on this menu, choose reset app preferences to make your phone forget the apps it's been trying to use. Now, head back in to your gallery and try playing a video!