Google Nexus S: Message Not Sent error

Google Nexus S: Message Not Sent error

Google Nexus S: Message Not Sent error

SOLVED
rahald
I'm a Participant Level 1

Google Nexus S: Message Not Sent error

Hello,

 

I bought a google Nexus S at my local Fido store a couple of weeks ago.  Now when I am sitting somewhere trying to text I will get a good amount of "Message Not Sent" errors.  Even if the network status shows as several bars.  I was previously a Rogers/IPhone4 customer I had no trouble with it in the same locations.  My girlfriend has a Fido BBCurve and it will send and receive no problem while she is sitting beside me.

 

I seem to be receiving texts in a timely fashion it just appears to be the sending that's the issue?  Any suggestions?  I have already removed any apps I installed since I first noticed the issue and have power cycled it a couple of times but it seems like it goes back to the old behavior soon after.

 

 

 

Accepted Solution

Re: Google Nexus S: Message Not Sent error

Solved by I'm Helpful Level 1

Pull out the app drawer, choose Messaging -> Press the menu button -> Settings -> Under SMS Settings, there is Message Center. You can change it to +15149931123

 

That should fix it. I am using Galaxy S Captivate.

View solution in context
4 REPLIES 4
FidoJenny
Former Moderator

Hello rahald,


Did you verify the Message Centre Number stored on your handset? It has to be set up to +15149931123.


Let me know.



Tomer
I'm a Participant Level 1

I'm sorry to tell you this, but Fido technical support are not very familiar with Android.

When I called them with the same problem, they told me to do a "Factory Reset" (!!!).

 

The solution for "message not sent":

1. Go to the system info by entering *#*#INFO#*#* (*#*#4636#*#*) .

2. Go to "Phone information".

3. In the SMSC field enter the following: 07915141991321f3.

4. Press "Update".

 

Good Luck.

Tomer.

Kingo
I'm a Participant Level 1

Hello,

 

I have tried the solution you gave but the error keeps on comming back. It is not permanent but the error keeps on comming back....

killer23d
I'm Helpful Level 1

Pull out the app drawer, choose Messaging -> Press the menu button -> Settings -> Under SMS Settings, there is Message Center. You can change it to +15149931123

 

That should fix it. I am using Galaxy S Captivate.