Galaxy S3 doesn't show my name on outbound calls

Reply
Highlighted
I'm a Participant Level 2
I'm a Participant Level 2

Galaxy S3 doesn't show my name on outbound calls

Anyone have any idea why?  I had the iPhone 4S and when I call people it shows my name, and my number on their call display.  So if I call a landline, or other Fido customer it shows my name calling.  Since I got the Galaxy S3 though for the name and number it just shows my number now when I call people, and on some call logs says Unknown Name and then my phone number for the number.  I did Fido live chat today and she said my name can't be blocked by Fido and works fine and that it's a problem with the landline I'm calling.  I told her it's not as Bell confirmed no name is being sent, and I also called my work VoIP system and the call logs say "Unknown" and then my number.  She said it must be a setting in the S3 that's blocking it then.

 

Does anyone know what setting that might be?  Haven't got much help anywhere else as I don't think many other providers show the name of the person on outbound calls for cell phones.  It's 100% the S3 as I just put the SIM in my iPhone and made a call and the name showed fine.

 

 

 

Accepted Solution

Re: Galaxy S3 doesn't show my name on outbound calls

You need to call Fido customer service to have this corrected. The setting are correct on your phone.

View solution in context
Flag this to a Moderator
Message 1 of 4
2,725 Views
Highlighted
Community Manager
Community Manager

Re: Galaxy S3 doesn't show my name on outbound calls

Hey essdddee,

 

If you go to Settings > Call > Additional Settings > Caller ID, is it set to "network" or something else?



Flag this to a Moderator
Message 2 of 4
2,710 Views
Highlighted
I'm a Participant Level 2
I'm a Participant Level 2

Re: Galaxy S3 doesn't show my name on outbound calls

Was set to Network.  I did a factory reset and it worked.  Went to bed for the night, got up and it doesn't work again so switched to the iPhone 5.

Flag this to a Moderator
Message 3 of 4
2,686 Views
Highlighted
I'm a Participant Level 3
I'm a Participant Level 3
Solution

Re: Galaxy S3 doesn't show my name on outbound calls

You need to call Fido customer service to have this corrected. The setting are correct on your phone.

Flag this to a Moderator
Message 4 of 4
2,676 Views