Fido.ca having issues, Again... this time about it's been about 3 weeks.... ETA on a fix?

Fido.ca having issues, Again... this time about it's been about 3 weeks.... ETA on a fix?

Fido.ca having issues, Again... this time about it's been about 3 weeks.... ETA on a fix?

amoclo
I'm a Participant Level 3

Fido.ca having issues, Again... this time about it's been about 3 weeks.... ETA on a fix?

I referred a couple of friends to Fido last month (June 2016).

Not a single one can register on Fido.ca because at the stage where you put in your Account #, and other information, errors... errors... and more errors... It won't process the information, even though it is exactly as is on the agreements as well as the fido system.

 

They can't use the app either to keep track of their usage, since it require the login, which can't be created...

So, suffice to say, they're not pleased with Fido.

 

It's common now for the site break once every couple weeks... which shouldn't be an acceptable thing

The app has it's own issues mind you

 

If the site/system change is this much over Fido's IT Department's capabilities, why was the change conducted in the first place.

 

Regardless of the many shortcomming of Fido as of late,

When can we expect the site to work properly this time around?

 

 

 

15 REPLIES 15
Cawtau
Senior MVP

Hello Amoclo,

 

  Welcome to the community!

 

  I'm not sure if this will help but I was in a similar situation with not being able to login with any browser. I found out that my internet security program was set to Private and blocking requests from social networks, web analytics, ad agencies, and web beacons. With Private disabled, I'm usually able to login without issue.

 

  Today, I was stuck in this semi-logged in state where the page showed my name but I was kicked-out every time I tried to access My Account or the community. For some reason, after waiting long enough I guess, it finally let me in. I think it has to do with the Lithium software that is being used. 

 

  Try disabling any privacy settings and allowing cookies, it may fix the errors.

 

  Hope this helps Smiley Happy

 

Cheers


amoclo
I'm a Participant Level 3

No internet security or anti-virus program conflicts.

Just the site being it's broken self.

 

No one at Fido seems to know when the issue will be resolved.

One of my friends activated a line on the June 15th.

Called in couple days later, because he couldn't sign up.

They told him over the phone, try a couple days later.

Next week, still no resolution. I went on live chat in his place to ask.

Was recommended to wait, but no definite time was given.

Another call, and another failed attempt a live chat, and here we are.

Nearly a month into the activation, and the guy doesn't have access to his account via Fido.ca and in relation, the app.

FidoMaria
Former Moderator

Hi @amoclo!

 

Thank you for giving your feedback.

 

Have your friends contacted us so we can fix the issue with their online accounts?



amoclo
I'm a Participant Level 3

As stated above, they did.

 

Only method they have available is calling into the customer support (611)

 

So they called in.

 

They were advised to wait, over and over, for weeks.

Hey @amoclo,

 

We'd be more than happy to help your friends and look into this with them! They will need reach out to us over here, or on Facebook or Twittter Smiley

 

Let them know Smiley

 

 



amoclo
I'm a Participant Level 3

They tried to get a hold of someone on Facebook and Twitter, but the fastest reponse was after a 2 hr wait, and no one can continue staring at their twitter or facebook app for that long.

Secondly, they can't get access to the forums, because as far as I know, you need your fido.ca account to actually work before they can leave a thread on here.

Hey @amoclo 

 

We're aware that we've had a bit longer waiting times than usual as we received a much higher volume of requests over the last few days. If they can continue the conversation with us ether on Facebook or Twitter I'm sure we'll still be able to get this sorted out for them. Smiley 

 

 



JJC1
I'm a Participant Level 1

I have the same issues - "Hang On... We're Thinking"...  And my wife just signed up for FIDO and she also has the same problem. I have spent considerable time trying to figutr this out and here is what I have...

 

The problems logging in and unique to a wifi connection. If you log in with a computer that is directly attached via an ethernet cable to a modem or gateway you will be logged in. If you are logging in over any wifi network using any machine or browser you cannot get in. This is a FIDO site problem. I tried logging in over wireless using Chrome, Firefox and Safari. Clean caches. Cookies on. I used tried with a MAC, 2 Windows machines and 2 iPads. And I tried different wi-fi networks. Same problem. Even the phone app has problems. It will partially sign you in if it is active on the cell network. Try to update your profile and it will force you to log in again and then hangs.

 

FIDO needs to put some plain old troubleshooting in place to isolate this.

FidoRanya
Former Moderator

Hey @JJC1

 

You should still be able to log in when connected to WI-Fi! This isn't right. 

 

I'll send you a PM to see what's going on Smiley



Maddog2
I'm a Participant Level 3

Good for you ! Personal attention - not a fix for everybody. 1 year later after this post I still can not log in into my account. Something needs to be change in Fido website !!!!

Hi @Maddog2!

 

What happens exactly when you try to log in? Do you get an error message? And are you using your e-mail address or your phone number as a username?



Maddog2
I'm a Participant Level 3

Hi, it takes forever to log in and  when finally I'm in my account -  Overview page not loading at all, other pages have script errors.

@Maddog2

 

Thanks for the reply.

 

And simply to confirm with you, like @FidoMaria said, are you using your phone number or email address as a username?

 

This can affect the access to your information on your account.

 

Let me know Smiley

 

 



KAPABLE-K
MVP

@amoclo Did your friends tried a different browser to register? 



amoclo
I'm a Participant Level 3

IE, Firefox, Safari, Chrome and Edge were all tried to register the accounts for the last 3 weeks

 

Fido really needs to get their IT department in order.

Their problems seem to be getting worse, rather than getting better.

I had another friend who tried to sign up to Fido today, and couldn't because their entire sales system was down.

He visited two separate stores in a span of 8 hours (one before work and one after)

It's like they don't really want to be a functional carrier...