Fido.ca & pop-up blocker

Fido.ca & pop-up blocker

Fido.ca & pop-up blocker

euser_name
I'm a Contributor Level 2

Fido.ca & pop-up blocker

Serviously... popups for the login? Who approved this failure of a design? Now I can't even log in to my account without having to turn off standard popup blocking and ad blocker. #Fail #YoureFired

 

8 REPLIES 8
FidoManuel
Former Moderator

Hey @euser_name!

 

Did you try to allow pop ups for Fido.ca, that's a common feature with any good pop-up blocker. You should be able to add our website to your green list!

That simple step, would fix your problem Wink



AlamyLiu
I'm a Participant Level 2

The Login pop-up window didn't show up, even unblock it (from all, from Fido, ...etc).

Guess the Firewall or Router (that I don't have control) had disabled some potential virus attack that the login script is using.

 

And I could login from the old page, but still unable to browse "My Account" as it seems to associated with the pop-up login function.

No worries! We are virus-free!

Can you confirm which browser you are using?



STang
I'm a Participant Level 3

I am also having this problem. I am using Firefox (tried all recent versions), and all of my add-ons are disabled. I have also disabled the built-in pop-up blocker. And javascript is enabled.  All that I can see when I click on "my account" is the picture of the people making stupid faces with the dog, but no login box appears.

 

Sure, I can log in using Chrome, but I shouldn't have to. No other site requires me to switch browsers, or worse still, water down my security settings to allow an awkward and non-standard login procedure. There is something wrong with the site that is preventing Firefox from seeing that pop-up. And why is a pop-up being used anyway?

 

Please fix this ASAP.

Hey @STang

 

Thank you for sharing this feedback. We have a team working on getting everything to run as smoothly as possible with our website. I'll be sure to forward this information to the right people for you. 



Sequoyah
I'm a Participant Level 2

The only way I can get the login to work on Firefox is to set  "Accept third-party cookies" to "Always".  Why do I have to do this? I prefer to keep my settings as they are and not have to remember to revert back just so that I can log in to one site. Come on Fido get your act together on this one.

gmsfido
I'm a Participant Level 1

I also have this problem (using Firefox). The above workaround works for me, but I am not prepared to leave my security reduced like this. I don't understand why Fido does not fix this.

Sequoyah
I'm a Participant Level 2

The same applies in Chrome.