Fido afilliated with Rogers?

Fido afilliated with Rogers?

Fido afilliated with Rogers?

SOLVED
mistyboo2
I'm a Participant Level 1

Fido afilliated with Rogers?

Just wondering,is fido afilliated with Rogers?

 

 

Accepted Solution

Re: Fido afilliated with Rogers?

Solved by MVP MVP
Hi

Fido is owned by Rogers but Fido remains a separate entity from Rogers.
View solution in context
6 REPLIES 6
KAPABLE-K
MVP

Hi

Fido is owned by Rogers but Fido remains a separate entity from Rogers.


deafwiggle
I'm a Contributor Level 1

I changed my provider from Rogers to Fido during Aug 2016. While doing so, I attempted to use the same email address for my Fido online account as I was using for Rogers, and Fido would not allow it (can't remember exact wording but Fido indicated it was already in use).

 

So, it appears that Fido and Rogers at least share user account information.

 

NB While doing this switch, I was told by a Fido rep that my Fido SIMs would (likely) work on Rogers-locked cell phones. I have not (yet) tried to do this, so cannot verify this either way.

Paolo
I'm an Expert Level 2

I know for a fact Fido sim did not work in a Rogers phone and vice a versa for myself.  As for the Rogers and Fido online Portals, they probably wanted to consolidate and provide one unified portal for both companies with seperate branding rather than pay to keep 2 of them running and 2x the maintenance and 2x the cost to support and upgrade. makes sense, no? fido and rogers share a lot in common already like the billing systems, HLR, antennas, etc.

FidoMaria
Former Moderator

Hi @deafwiggle & welcome to the Community!

 

Using your old Rogers username would not prevent you from using it with Fido. When you activate an account with Fido, your e-mail address is automatically registered, and we send you a link to complete the registration on Fido.ca. This may be why you were getting a message that the e-mail address was already in use.

 

As for using a Fido SIM in a Rogers phone, the phone would need to be unlocked.

 

Hope this helps. Cheers! Smiley



deafwiggle
I'm a Contributor Level 1

Thank you for your comments, Maria. To clarify:

 

I tried to use the same email address I used from my Rogers online account when setting up my Fido online account. In hindsite, this email address is also a Rogers - and now a Fido - username. I did not recieve a "registration completion" email. I verified this by trying to recover the Rogers account. Ran into issues with that (see Note below) - which I'm not sure I'm willing to pursue (I am entirely disenamoured of the Rogers and Fido web sites; abysmal performance, flakey page generation, sometimes have to refresh multiple times just to get anything to display, have to re-login to do nearly anything, and a lot of stuff is apparently broken).

 

Notes:
- The discussion of Rogers-to-Fido account migration is somewhat moot for me as I now have my Fido account set up using a different email address, and I can manage my cell services with it.
- With your comments in mind, I requested a password reset on Fido for the email address I'm using on Rogers. It took well over 1/2 hour to get the email it sent. Then, when I selected a new password, it took at least another 1/2 hour to get the confirmation email. Then, Fido asked me to enter a new password again (entirely redundantly), and then, to top things off, the Fido site wouldn't accept a verification code it texted to me. Tedious and frustrating. I've left that account in limbo (I may take another run at it another day). Hopefully I won't have to do that very often...

 

Aside: When anything related to the fido.ca domain name is used (i.e. these forums, or the main site), a TON of links to Rogers (amongst other services) flash past in my browser's status bar. This is a clear indication that Fido does rely on services from Rogers. (Without employing tracers - which I'd be loathe to do anyway - it's difficult to say exactly how deep those reliances run.)

 

No biggie about the Fido SIMs not working on Rogers-locked phones. Just an interesting aside. Next time I'm in their neighbourhood, I may let my local Fido rep know.

 

Sincerely,
Dirk

 

PS This form is not allowing me to enter the letter "x" (I had to cut'n'paste it everywhere needed), and if I attempt to type the letter z (also has to be cut'n'pasted to enter), I'm punted out of this form (it loses everything I entered - as though I never tried to reply).

Thanks for the details  @deafwiggle  , we'll continue this in PM Smiley .