Fido Home Phone message indicator is not working properly

Fido Home Phone message indicator is not working properly

Fido Home Phone message indicator is not working properly

SOLVED
ceciliawong888
I'm a Participant Level 3

Fido Home Phone message indicator is not working properly

I recently got my Fido Home Phone which great because I get to keep my land line number. The set up works fine except for the voice message indicator. It does not do anything (no green light blinking) when there is a message, it starts blinking after the message is retrieved. Then the green light continues to blink and never goes away even after all messages are deleted. The only way you can get it to stop blinking is by turning the device off and on. Then the whole issue repeats.

I talked to Fido on phone and by live chat, they tried to help but nothing works. I was suggested to go back to the store there I was given a new SIM card, it didn't help. Then the store tested on a new modum, the same problem occurred.

It appears that this part of the device or modum was not tested properly before leaving the factory.

 

 

 

Accepted Solution

Re: Fido Home Phone message indicator is not working properly

Solved by Community Manager

Hi everyone,

 

The update for the WF721 is now available. This update will improve touch tone performance and address a bug with the message waiting indicator.

 

Click here for more info.

View solution in context
53 REPLIES 53
SgtWilko
I'm Helpful Level 1

Thought I'd update my own WF721 saga's happy conclusion and thank all the Fido CS reps who patiently helped along the way. I hope Fido does well by these dedicated people and gives them improved tools and training to better assist them in helping Fido customers.

 

I initially jumped into this thread last March. I have finally been able to get an updated WF721 that resolves the message waiting indicators and the touch tone issues. It took 5 months and 3 units to get one that had the firmware update already installed. The first two would not take the update despite several attempts with Fido CS.

 

The only remaining issue for me is the that the number of rings before answering is not adjustable and fixed at 4 rings. That forces users who use both their phone VM and the Fido VM (as backup when on the phone, power is out, or phone VM is off) to set their phone VM to answer after 3 rings or less. A little short for most... except maybe for Usain Bolt. 

 

Fido CS reps were helpful and willing as usual but not always sufficiently informed or trained. It took months to get this resolved due to the multiple tries with different CS reps, re-explaining the issue and repeating the same scripted (and inadequate) troubleshooting processes before giving up and going the replacement route. 

 

I have no problem with Fido CS reps' willingness to help. They genuinely try very hard. However, Fido needs to keep their CS people better informed and trained. They also need to improve their remote servicing capabilities for things like firmware updates and general troubleshooting. My little WF721 adventure has cost Fido three modems and a bunch of time wasted by their CS and Tech support organizations.  Not to mention my own wasted time and frustration which wiped out a good chunk of my confidence in Fido. Not ideal for a service oriented company.

 

Hopefully, the recent 30% hike on the home phone monthly fee will indeed bring the quality and reliability Fido touted to justify it. Not holding my breath but would be happy to be proven wrong.

 

Sgt Wilko

jpennycook
I'm a Participant Level 3

Ok, so I have my new ZTE 721 and a new Panasonic 5 reciever phone system. I seem to be able to access the ZTE message center, hear messages and delete them. However, I'd like to turn the ZTE message center off and use the much better one in the Panasonic system.

 

It seems I read above that the only way to do this is to set the Panasonic system to pick up after 3 rings. CORRECT? Not a handy solution in our household. Any other work arounds? Thanks

Sending you a PM now @jpennycook so we can look into this for you. Smiley

 



jdoeuser
I'm a Participant Level 2

Hello,

 

I'm having the same issue and already called Fido to get this fixed.   Unfortunately, nothing has been resolved so far...

 

Please help...

Hi @jdoeuser

Welcome to the Community! 

The issue should be resolved once the update is done. Was it completed properly?

I'll go ahead and send you a PM so we can check it out!

Talk to you soon Smiley

 

 



jdoeuser
I'm a Participant Level 2

Hello FidoAlyson,

 

Just want to let you know that I already received the replacement WF721 home phone device you sent.   Went ahead and tested the new WF721 using the SIM from the existing WF721 and voila!, my voicemail message indicator is now working and I believe the issue is now resolved...yay!

 

Again, Thank you very much for your fast, efficient, and excellent service...

Awesome to hear everything works now and thanks for updating us on the situation. Smiley



ceciliawong888
I'm a Participant Level 3

I just got back from vacation and tried the new update as instructed, it didn't work. The message indicator is still not working properly, same as before.

Do I have to get a replacement devise to get it to work? 

Hey @ceciliawong888,

 

did you contact customer service so they can help you with the update on the device? 



ceciliawong888
I'm a Participant Level 3

I just contacted customer service and got help with the update, the message indicator is now working perfect. Thank you very much.

Thanks so much for keeping us updated 😃

 

Really appreciate it!



ceciliawong888
I'm a Participant Level 3

Hi, I received a email from Fido yesterday regarding a new software update for the ZTE Fido Home Phone device for improving the touch tone performance.  I followed the instructions provided in the email but no installation process was made. I called Fido support and was told that I should go to the store and exchange the device, but then staff at the store said that they had never heard about it.

I'm just wondering if this update is the same one as the one for fixing the message indicator back in April, and may be that's the reason why I can't do this update since it was already updated?

Please advise as soon as possible, so that I know if I should go back to the store to struggle with the staff for an exchange. Thanks.

@ceciliawong888 I'll send you a PM to check what's going on. Smiley



Reptileskin
I'm a Participant Level 1

I have the same problem here... got the machine a few days ago...disapointed...the Fido seller should have told me that they were have this issue with the device. Sad

Hey @Reptileskin

 

We hear you! We're working to get this resolved and will let everyone know once it's taken care of. Smiley 



Hi everyone,

 

The update for the WF721 is now available. This update will improve touch tone performance and address a bug with the message waiting indicator.

 

Click here for more info.



SgtWilko
I'm Helpful Level 1

Arrrggh! Ive been on the phone with a Fido CS agent for 10 minutes and he had NO CLUE whatsoever about the WF721 update or what he had to do on his end to activate it for my account!

 

I directed him to the community post and he is reviewing it now:smileyfrustrated:

SgtWilko
I'm Helpful Level 1

Hello @FidoStephen,

 

The WF721 firmware update announcement was great news, and the update procedure looked dead simple.

 

Unfortunately...

 

Two Fido CS agents, 45 minutes on the phone, and 3 attempts later, It seems the update is not working with my WF721 modem. What I understood from the agents is that they have to do a "Resend to switch" in the account before a user can go through with the power off/on update procedure. The three attempts all failed, with the WF721 simply powering up in normal mode (no blinking lights or red signal strength bar indicating an update in progress). Yes, I waited several minutes after the power OFF/ON sequence to allow the firmware to download but I never saw the light patterns described in step 3 of the update instructions. The WF721 just seemed to power up and oprate in normal mode.

 

Then things went from bad to plain ridiculous. I was told to go to a Fido boutique to get this sorted out. When I asked if I should go WITH the WF721 in hand, the agent told me that I should NOT bring it. When I asked what the Fido boutique people would be able to do if I showed up there empty handed, there was a pause ;o) I suggested I really should bring the WF721 with me, the agent said that wouldn't work because I would have to disconnect the modem (???). While I argued with her that the Fido boutique people would not be able to do anything for me if I showed up empty handed, she finally realised that the WF721 IS A BLOODY CELLULAR MODEM!!! It can be powered up at the Fido shop and it will work there the same way it works at my home Confused

 

So its back to the WF270 for now. I'm going to wait for some other users to post some kind of success before trying again... or going to a Fido store, WF271 in hand Angry

 

 

Hey SgtWilko,

 

I'm sorry if you had issues updating the modem. You should of been transferred to our technical team if you're having issues with the update. Did you get a chance to do that? 



gcrmt
I'm a Contributor Level 2

SgtWilko isn't the only one who is experiencing the same issues.  I tried rebooting twice yesterday myself, plus an additional two times after speaking with Fido.  No go, the modem boots up normally without any additional downloads & installation.  Even the CSR didn't even know anything about the issue.  ????

 

Yup.... good fix.  Confused