Enable Wi-Fi Calling

Enable Wi-Fi Calling

Enable Wi-Fi Calling

ClaudeYJL
I'm a Participant Level 2

Enable Wi-Fi Calling

I just switched from Rogers to Fido. I tried to enable Wi-Fi calling on my iPhone 6s, but it keeps saying "To allow Wi-Fi Calling on your account, contact Fido." I tried every possible solutions like taking the sim card out and putting it in back, turning the phone off and on, resetting the network setting, and adding IMEI number of my iPhone on my account (I purchased my iPhone directly from Apple Store), but still doesn't work.

 

Should Fido enable wi-fi calling feature for my account?

 

 

4 REPLIES 4
KAPABLE-K
MVP

@ClaudeYJL The problem could be that you did not get the iPhone directly from Fido and your phone IMEI is not in Fido's database so it won't activate the WiFi option.



ClaudeYJL
I'm a Participant Level 2

My dad's iPhone is iPhone 6 plus, which is unlocked and directly purchased from Apple Store. Wi-fi calling is working on his phone.

The IMEI number of my iPhone has been added on my account and I saw that the account info indicates that my phone is iPhone 6s.
lingxiao_yang
I'm a Participant Level 1

I had same issue as yours, I took me over 2 months, countless phone calls with Fido customer services, and various trys...and today, one customer services fixed it for me: he deleted SOC code from my account, and then put it back again...then I am able to enable the wifi-calling function...You probably can call fido and ask them try this out on your account. I will give it a couple days to see if it stays.

Hey @ClaudeYJL,

 

Thanks for the details. Can you tell us the exact steps you took to enable wi-Fi calling tin the settings of your phone?