Dropping calls on Samsung S6

Dropping calls on Samsung S6

Dropping calls on Samsung S6

Cris7
I'm a Participant Level 1

Dropping calls on Samsung S6

I've started to have constant drops while I'm on the phone and I think that is related to weak signal. I have a Samsung S6 bought in Dec.2015 so a brand new phone.
I was thinking that touching somehow the phone's display to my ear I'm causing that but yesterday trying to call 3 times my bank through my hands free it dropped 3 times the call. Moving about 100 m I've succeeded to make that call.

Any ideas? Thank you in advance.

 

 

 

2 REPLIES 2
AdamBeast
Fido Employee

To disable LTE mode, you need to go to Settings -> More Networks -> Mobile Networks -> Network Mode -> select WCDMA/GSM auto connect instead of LTE/WCDMA/GSM auto connect. 

You can also refer to this video here for more info. 



FidoManuel
Former Moderator

Hey Cris7!

 

Welcome to the Community!

 

Since you mentioned that by moving about 100 m you get better reception, I'm thinking about a location problem. 

There might be a blind spot at that location, I'll ask you to try and disable the LTE and test again. 

You should see a nice improvement. 

Keep me updated with the results.