Can't login from desktop. Solution!

Can't login from desktop. Solution!

Can't login from desktop. Solution!

Vic
I'm a Participant Level 2
I'm a Participant Level 2

Can't login from desktop. Solution!

This is my first post in the forum. So I apologize if I'm in the wrong category.

 

Over the last 2 weeks I hadn't be able to access My Account from ANY desktop PC. Both Windows and Mac based. I tried all the popular browers (Safari, Firefox, Edge, Chrome) with the same end result.

 

Then one day I tethered my iphone to my laptop and logged in with no issues at all. Previously on my home wifi I couldn't log in from that same machine.

 

I started to suspect something was wrong with my routers settings.  I had a hunch that there was problem with DNS resolving properly. Normally it's very forgiving for most sites. As a test I changed the dns setting in my browser to google's dns 8.8.8.8  and logged into this site fine. But changing this on every device I own would be tedious.

 

So I looked through my router settings.  I have an Archer C7.  My setup is Rogers modem/router set into gateway mode (router function disabled)>TP-Link Archer C7.  What I found was that my Archer C7 was using  the modems internal IP as dns 192.168.0.1

 

If you happen to have the same router or a similar TP-Link model follow these steps to fix your issue.

 

1.) Login to your router

2.) Go to the status page, and look for the WAN section

3.) At the bottm of the WAN section it says 

     DNS Server: xx.xx.xxx.xxx, xx.xx.xxx.xxx 

     Write the number you see down.

4.) Go to the Network setting. Make sure the the box Use These DNS settings is checked. And that the numbers match the ones you wrote down in the previous step.

 

5.) Go to System tools>Reboot.

 

Hopefully you should be able to login to Fido.ca now.

 

 

 

1 REPLY 1
FidoStephen
Community Manager

Hey @Vic and thanks so much for your post!

 

Hopefully it'll help out other members if they encounter the same issue Smiley