Can't Upgrade Iphone

Can't Upgrade Iphone

Can't Upgrade Iphone

bigboi95
I'm a Participant Level 1

Can't Upgrade Iphone

I have tried literally everything- lets see if the wonderful community knows whats going on!!

 

So Im just trying to upgrade my BYOP plan to a Large Agreement plan with an Iphone 7 (32gb Rose Gold) and I keep getting this weird error message....

Screen Shot 2018-05-09 at 12.54.44 PM.png

 

I only get this with Iphone (could be a sign to switch to samsung haha) but I know there has to be a way around it.  I have tried with Firefox, Chrome, and even Safari!!  I just keep getting this before I can even check out- its a major bummer.

 

As per the instructions I recieved over the phone after calling the number that this window gives me yes I am logged in and yes my cache is empty.  

 

My process is (google "Fido Upgrade"(because that doesnt even show up)->Click Link->Click "Iphone 7 32 gb Rose Gold"-> Click fancy promo Large plan-> Get error) EVERYTIME.  I dont know maybe Im clicking wrong.....

 

Does anybody know how to get past this issue?

 

 

1 REPLY 1
FidoGabrielle
Former Moderator

Hey there @bigboi95!

 

Welcome to the community. Smiley

 

Looks like you've pretty much tried everything already, eh? 

 

PM on the way!