10GB Plan - SLOW SERVICE WITH FIDO

Service interruption


An update for our valued customers: We know you depend on us and on April 19, we let you down - for this we are truly sorry. You won’t be charged for your wireless services that were impacted on Monday, April 19. A credit equivalent to that day's wireless service fee will be applied to your May bill. This will be done automatically & no action is required by you.

Click here to read more

10GB Plan - SLOW SERVICE WITH FIDO

10GB Plan - SLOW SERVICE WITH FIDO

kelzos
I'm a Participant Level 2

10GB Plan - SLOW SERVICE WITH FIDO

Hey Everyone,

I recently switched with Fido , on their 10gb plan. After being with Freedom (formerly WIND) and having terrible service for some time , I decided that the 10gb plan along with the trusted service of Fido I would have a bettter quality of service. However after being with Fido for close to a month I have seen multiple dropped calls. Slow data reception and overall terrible service quality. I live in Toronto ( North York and Scarborough border) . Has anyone else experienced this problem. It is getting very tiring and upsetting since I am paying more than I did with Freedom but feel I am getting the same type of service .

 

3 REPLIES 3
trevorc
I'm a Contributor Level 1

What phone are you using? Hopefully one that doesn't just have the AWS bands.

kelzos
I'm a Participant Level 2

@trevorc I have a one plus 2 , I believe I have a lot of bands from the specs that I saw online

Hello Kelzos,

 

  Welcome to the community!

 

  Did you also use the OnePlus 2 with Freedom? If you did, your phone is likely the North American version of the device (see here). If that is the case, the phone would be fully compatible with the networks. On the other hand, if you didn't use the OnePlus 2 with Freedom, it's possible the phone only has one compatible LTE band/frequency, band 7 or 2600MHz (ie European/Asian version).

 

  Have you verified the phone is using the proper APN? Since the device is LTE-capable, it should be using ltemobile.apn. You can verify those settings here.

 

  Are you having the same issue everywhere? Or is it limited to certain locations. Cellular reception is influenced, in part, by your location relative to the cellular towers. Depending on your location along the North York and Scarborough border, you may be on the edge of coverage. You can get an idea of your surrounding towers here.  You should note that other factors can also influence how well signal can reach your phone. For example, buildings can be a source of interference, limiting the amount of signal which can pass.

 

  Are you able to note to which network your phone connects? Have you verified that your network mode is set to GSM/UMTS/LTE? Have you tried to disable LTE?

 

Hope this helps Smiley

 

Cheers