Showing results for 
Search instead for 
Did you mean: 

My Account not loading

I'm a Participant Level 2
I'm a Participant Level 2



I'm having issues with the My Account App.

When I try to open it all I see is the loading page with the girl looking at her phone and the cog spinning.


Everything is up to date:

iOS version 12.2

App version 3.8.2


I have tried reinstalling it, restarting my phone in the process.

I've tried resetting my phones network settings.

I've tried it on both wifi and mobile data.

Nothing works.


There is no error messages or anything to tell me what is happening. 

I simply see an indefinite loading page.


Help would be appreciated.


Former Moderator
Former Moderator

Hey @BlockToe


Welcome to the community🙂


Thanks a lot for confirming the details above. 


What do you use as your username? Phone Number or Email Address?

Can you also confirm if you are able to log into My Account from a browser page? 

I'm a Participant Level 2
I'm a Participant Level 2

Hi @FidoJo 

Yes my login is working fine everywhere else, and it also has been working fine in the app until lately.
Now I don't even see the option to login.


I also spoke with FIDO support yesterday, which did not resolve the issue, but did get it escalated to their techs to investigate further (case number: C143385852).


I'm told the turn around on that is about 20 days, but hopefully they can find a solution.