Showing results for 
Search instead for 
Did you mean: 

Fido app unusable, stuck at Recapcha

I'm a participant level 1
I'm a participant level 1

Unable to log in My Account App, everytime I tried it asks if I'm robot, then give me Recapcha pictures.


After completing fives or so it says "please try again" and give me another five. And it just keeps giving more Capcha tests.


I tried for 20 mins and still can not get pass, it's very frustrating. It's more like trying to keep human away, because if anyone can pass that would be robots.


Is there a solution for bugs like this?




Hey @RichardXu1 Smiley

I'm sorry to hear you're facing this issue with the app! 


Could you please confirm the following, so we can assist you to the best of our abilities? 


1. Do you have an Android device, or an iPhone?
2. Have you tried to uninstall and reinstall the app? 

3. Is your software up to date? 


Let us know. 

I'm qualified level 1
I'm qualified level 1


I think u have a problem with internet cookies or your ip address is rejected when trying to communicate with fido sql servers or something at login.

Have u tried to switch on another internet network or devicei think its should resolve your problem.

Smiley Have a nice day 

It's been a pleasure to assist you today Smiley

Dont forget to mark my answer as the best if u want Smiley